Forum

Author Topic: Issue of orthophoto with DJI Phantom4 Multispectral  (Read 4704 times)

jguan

  • Newbie
  • *
  • Posts: 5
    • View Profile
Issue of orthophoto with DJI Phantom4 Multispectral
« on: February 23, 2021, 02:04:07 PM »
Hi everyone,

Since March 2020, we have started to use Agisoft Metashape Pro to generate multi-spectral orthophoto with the photos taken by DJI Phantom4 Multispectral.

There are at least one hundred orthophotos that have been generated, in most of these orthophotos, we have found this problem (see the attachment): There are alternately spaced ribbons on the orthophoto, and are consistent with the drone's flight path. It seems that more camera calibration may be needed. But there doesn't exist a panel calibration for this drone.

Does anyone else encounter the same problem, is there any good solution?

Thanks a lot.

Jeany

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14890
    • View Profile
Re: Issue of orthophoto with DJI Phantom4 Multispectral
« Reply #1 on: February 23, 2021, 02:48:33 PM »
Hello Jeany,

Are you applying the reflectance calibration operation before building the orthomosaic?

Can you please check, if the problem is still observed in the version 1.7.2 pre-release (you need to run Calibrate Reflectance operation based on the Sun Sensor data prior to the orthomosaic generation procedure):
http://download.agisoft.com/metashape-pro_1_7_2_x64.msi                    - Windows 64 bit
http://download.agisoft.com/metashape-pro_1_7_2.dmg                          - macOS
http://download.agisoft.com/metashape-pro_1_7_2_amd64.tar.gz           - Linux 64 bit
Best regards,
Alexey Pasumansky,
Agisoft LLC

jguan

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Issue of orthophoto with DJI Phantom4 Multispectral
« Reply #2 on: February 24, 2021, 08:07:15 PM »
Thanks for your reply.

We have tried with this new version beta. And please find the orthophoto generated in the attachment.

Seems like there is always this problem.  More details in the second image.

Do you have any research about it?

Best regards.

Jeany

 

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14890
    • View Profile
Re: Issue of orthophoto with DJI Phantom4 Multispectral
« Reply #3 on: February 24, 2021, 08:46:58 PM »
Hello Jeany,

You can adjust the brightness for the visual convenience using Set Brightness command.

If you use Raster Calculator dialog for NVDI calculation, then do additional adjustment will be be required.
Best regards,
Alexey Pasumansky,
Agisoft LLC

jguan

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Issue of orthophoto with DJI Phantom4 Multispectral
« Reply #4 on: February 25, 2021, 12:23:00 PM »
Hello Alexey,

There are always these alternately spaced ribbons on the orthophoto in each channel of the camera, this does not seem to be a problem of adjusting the brightness.

Through the NDVI image, we can see the problem more clearly in the attachment.

By the way, what kind of additional adjustment can we apply after using Raster Calculator?

Thanks a lot.

Jeany






sven_a

  • Newbie
  • *
  • Posts: 19
    • View Profile
Re: Issue of orthophoto with DJI Phantom4 Multispectral
« Reply #5 on: March 01, 2021, 12:45:24 PM »
We often see similar issues. Seems to be following exactly the seamlines so might also be related to image blending (next to flight conditions, camera calibration). We had this issue with this sensor but also with MicaSense RedEdge & Altum.

sven_a

  • Newbie
  • *
  • Posts: 19
    • View Profile
Re: Issue of orthophoto with DJI Phantom4 Multispectral
« Reply #6 on: March 18, 2021, 08:33:15 PM »
Different dataset offcourse than mention in this thread but issues seems 99.9% the same. We still have the issue in 1.7.2

nprokofyev

  • Newbie
  • *
  • Posts: 22
    • View Profile
Re: Issue of orthophoto with DJI Phantom4 Multispectral
« Reply #7 on: March 30, 2021, 12:10:44 PM »

Through the NDVI image, we can see the problem more clearly in the attachment.


I see the problem but have no clue what caused that. Could you process up to orthomosaic WITHOUT calibration at all, I'd like to make sure the calibration process is a reason.


We often see similar issues. Seems to be following exactly the seamlines so might also be related to image blending (next to flight conditions, camera calibration). We had this issue with this sensor but also with MicaSense RedEdge & Altum.

Hi, could you show a couple of examples?  The sample shown seems like whole lines lost their contrast completely.

sdieten

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Issue of orthophoto with DJI Phantom4 Multispectral
« Reply #8 on: October 15, 2021, 06:05:54 PM »
Hey all,
I am processing P4 Multispectral images (Metashape version 1.7.5) and have the same issue: in some parts of the orthomosaics created every second ribbon has a lower texture, looking more blurry. Turining of the sun sensor prior to the generation of the orthomosaic often resolves the issue but sometimes introduces artefacts due to different lightning conditions. In some cases it also helped to turn off the reflectance calibration (we are using a MicaSense reflectance panel).

Has there been a solution found to this issue so far?

Biberfachstelle

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Issue of orthophoto with DJI Phantom4 Multispectral
« Reply #9 on: February 08, 2022, 02:10:07 PM »
Hi there
the last post without a solution was october 2021. Is there a solution? Has Agisoft found a way to solve this problem?
thanks a lot
Christof