Forum

Author Topic: VK error GPU textures generation  (Read 314 times)

Iluvathar

  • Newbie
  • *
  • Posts: 27
    • View Profile
VK error GPU textures generation
« on: April 15, 2021, 03:56:57 PM »
Hello
I have this error during textures generation on my model. Here is the console detail :
do you have any ideas ?
Is it a bug or should i reduce the polycount ?
Thanks !

Parameterizing texture atlas...
Model size: 196461271 faces, 98219395 vertices
Decimated to 1000000
Performing initial subdivision...   
Division threshold 100000
chart  0 faces: 97663
chart  1 faces: 84181
chart  2 faces: 78613
chart  3 faces: 77074
chart  4 faces: 72911
chart  5 faces: 72035
chart  6 faces: 66696
chart  7 faces: 65985
done. (in 3.505 sec). Got 373 initial parts.
top 8 mean: 76894.8 stddev: 9681.93
*************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************
Scaling charts... 
done. (in 1.42 sec)
Concatenating charts... 
done. (in 0.046 sec)
Packing... 
Parametrization contains 30152 charts
Pack iteration 0 ratio 0.525
Pack iteration 1 ratio 0.3875
Pack iteration 2 ratio 0.45625
Pack iteration 3 ratio 0.490625
Pack iteration 4 ratio 0.473437
done. (in 1667.53 sec)
Retrieving mesh
Parameterizing done in 2280.41 sec
Blending textures...
Found 1 GPUs in 0.147 sec (CUDA: 0.034 sec, OpenCL: 0.113 sec)
Using device: NVIDIA Quadro RTX 8000, 72 compute units, free memory: 47721/49152 MB, compute capability 7.5
  driver/runtime CUDA: 11030/8000
  max work group size 1024
  max work item sizes [1024, 1024, 64]
  got device properties in 0 sec, free memory in 21.68 sec
All cameras are fine
Initializing context...
Found device NVIDIA Quadro RTX 8000 driver version 1954725888, API version: 1.2.168, location 129::0
calculating mesh connectivity... done in 69.737 sec
Initialized texture renderer
Configuring pipeline...
Initialized memory broker
Configuring mosaic pipeline with outliers filtering
Constructed pipeline
Relaxed precision enabled
Collecting memory requests...
Allocating memory requests...
Estimated required video memory: 13297 MB
Estimated device memory: total 48708 MB, used 221 MB, available 47940 MB
Allocated 13319 MB of VRAM

Allocated memory requests
Configured pipeline
Processing cameras...
Loading mesh...
Cannot use GPU. Reason: VK Error : VkResult is "ERROR_OUT_OF_DEVICE_MEMORY" at line 12
Performing blending on CPU...
calculating mesh connectivity... done in 67.325 sec
detecting outliers...

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 12851
    • View Profile
Re: VK error GPU textures generation
« Reply #1 on: April 15, 2021, 07:32:59 PM »
Hello Iluvathar,

Which NVIDIA driver version you have installed on this machine.

Also please specify the texture generation parameters that you are using and describe the project, where the texture for 200 M poly model is required.
Best regards,
Alexey Pasumansky,
Agisoft LLC

Iluvathar

  • Newbie
  • *
  • Posts: 27
    • View Profile
Re: VK error GPU textures generation
« Reply #2 on: April 16, 2021, 11:01:26 AM »
Hello Alexey,
I installed the latest drivers : Quadro release 465 version 466.11 i used for diffuse map, source : images, mapping : generic, fusion : Mosaïc.
i needed a 8k texture and the UV of the most detailed model i build from a XIX century monument that have a lots of architectural decor. I want in a second time transfer my diffuse map on a hily reduced model with baked normals and occlusion map. I usually use the texture transfer from my high poly model to have the most accurate mapping on the low poly model.

Best regards