Forum

Author Topic: destructed model when exporting to geo-refrence system  (Read 1018 times)

majou

  • Newbie
  • *
  • Posts: 29
    • View Profile
destructed model when exporting to geo-refrence system
« on: February 27, 2021, 01:30:42 PM »
Dears,

I work with Geo-refrenced models, therefor I set up the reference settings to match the coordinate system\zone of my projects.
whenever I export my models (any format) and choosing the same coordinate system  from the export window, the models turns out very destructed same as below. But when I keep the setting in the export window for "local coordinates" it turns out fine, however I mostly need the model to export to match their Geo-refrence location\orientation.

would appreciate your thoughts on this matter, I have no idea what is going on with it.




Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14099
    • View Profile
Re: destructed model when exporting to geo-refrence system
« Reply #1 on: February 27, 2021, 02:34:19 PM »
Hello majou,

Most likely the post processing or viewing application that you are using doesn't support large coordinate values - in most projected coordinate system X and Y coordinates are measured in hundreds of thousands or even millions of meters (or feet). If the external application is using 8-bit float type to save the coordinates of the mesh vertices, the decimal digits and some lower order digits will be truncated, which will result in the observed issue.

So you either should use Local Coordinates, which keeps the orientation and scale, but not absolute location of the model. Or use Shift values for X and Y to export the model with the fixed XY offset, compared to the original location.
Best regards,
Alexey Pasumansky,
Agisoft LLC

majou

  • Newbie
  • *
  • Posts: 29
    • View Profile
Re: destructed model when exporting to geo-refrence system
« Reply #2 on: February 27, 2021, 02:53:11 PM »
Hi Alexy,

indeed it is a large area in real-life.
Thank you for the explanation, it shed some light. will run some experiments accordingly and update the post later.

P.S. thanks for your prompt answers all the time, it makes my life easier. :)



Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14099
    • View Profile
Re: destructed model when exporting to geo-refrence system
« Reply #3 on: February 27, 2021, 03:08:54 PM »
Hello majou,

The problem is not related to the dimensions of the covered area, but to the absolute coordinates in the selected projected coordinate system.
Best regards,
Alexey Pasumansky,
Agisoft LLC