Forum

Author Topic: CL_BUILD_PROGRAM_FAILURE (-11) at line 1087  (Read 3124 times)

David Cockey

  • Full Member
  • ***
  • Posts: 207
    • View Profile
CL_BUILD_PROGRAM_FAILURE (-11) at line 1087
« on: February 27, 2021, 06:58:37 AM »
Updated to Agisoft Metashape 1.7.1 Windows Standard Edition

Aligned photos.

Started Build Dense Cloud
2021-02-26 22:56:58 Building kernels for AMD Radeon HD 7700 Series (Capeverde)...
2021-02-26 22:56:59 Device 1
2021-02-26 22:56:59    Program build log:
2021-02-26 22:56:59 Error: Undeclared function index 1028
2021-02-26 22:56:59
2021-02-26 22:56:59
2021-02-26 22:56:59 Failed to compile binary dumped to C:/Users/David/AppData/Local/Agisoft/Metashape/cache/kernel_cache/pm_undistort_templated4098AMD Radeon HD 7700 Series (Capeverde)_FAILED
2021-02-26 22:57:00 Finished processing in 3.884 sec (exit code 0)
2021-02-26 22:57:00 Error: ciErrNum: CL_BUILD_PROGRAM_FAILURE (-11) at line 1087

David Cockey

  • Full Member
  • ***
  • Posts: 207
    • View Profile
Re: CL_BUILD_PROGRAM_FAILURE (-11) at line 1087
« Reply #1 on: February 27, 2021, 07:03:49 AM »
I tried building dense cloud using a project which had built a dense cloud using previous version on 9 January 2021 and had the same failure.

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14010
    • View Profile
Re: CL_BUILD_PROGRAM_FAILURE (-11) at line 1087
« Reply #2 on: February 27, 2021, 02:29:33 PM »
Hello David,

Which AMD driver version is installed on your system?

Does it help to install the latest available drivers that are compatible to your system from the following page?
https://www.amd.com/en/support
Best regards,
Alexey Pasumansky,
Agisoft LLC

David Cockey

  • Full Member
  • ***
  • Posts: 207
    • View Profile
Re: CL_BUILD_PROGRAM_FAILURE (-11) at line 1087
« Reply #3 on: February 27, 2021, 04:12:35 PM »
AMD driver is 27.20.1034.6  8/21/2020.  I will update to latest from AMD.

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14010
    • View Profile
Re: CL_BUILD_PROGRAM_FAILURE (-11) at line 1087
« Reply #4 on: February 27, 2021, 04:27:52 PM »
Hello David,

If the issue persists, please provide the complete log from the Console pane related to the failed operation.
Best regards,
Alexey Pasumansky,
Agisoft LLC

David Cockey

  • Full Member
  • ***
  • Posts: 207
    • View Profile
Re: CL_BUILD_PROGRAM_FAILURE (-11) at line 1087
« Reply #5 on: February 27, 2021, 04:59:35 PM »
Failed again after updating AMD graphics driver to 27.20.14535.3005 2/17/2021


2021-02-27 08:55:35 Agisoft Metashape Standard Version: 1.7.1 build 11797 (64 bit)
2021-02-27 08:55:35 Platform: Windows
2021-02-27 08:55:35 CPU: Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz (desktop)
2021-02-27 08:55:35 CPU family: 6 model: 58 signature: 306A9h
2021-02-27 08:55:35 RAM: 16.0 GB
2021-02-27 08:55:35 OpenGL Vendor: ATI Technologies Inc.
2021-02-27 08:55:35 OpenGL Renderer: AMD Radeon HD 7700 Series
2021-02-27 08:55:35 OpenGL Version: 4.6.14760 Compatibility Profile Context 21.2.3 27.20.14535.3005
2021-02-27 08:55:35 Maximum Texture Size: 16384
2021-02-27 08:55:35 Quad Buffered Stereo: not enabled
2021-02-27 08:55:35 ARB_vertex_buffer_object: supported
2021-02-27 08:55:35 ARB_texture_non_power_of_two: supported
2021-02-27 08:55:53 LoadProject: path = C:/Current Projects/MMM Peapods/Merrill Young 1964/Metashape/MY1964-001.psx
2021-02-27 08:55:53 Loading project...
2021-02-27 08:55:53 loaded project in 0.396 sec
2021-02-27 08:55:53 Finished processing in 0.403 sec (exit code 1)
2021-02-27 08:56:28 BuildDenseCloud: quality = Medium, depth filtering = Aggressive, PM version, point colors = 1
2021-02-27 08:56:28 Generating depth maps...
2021-02-27 08:56:28 Preparing 163 cameras info...
2021-02-27 08:56:28 cameras data loaded in 0.386 s
2021-02-27 08:56:28 cameras graph built in 0.151 s
2021-02-27 08:56:28 filtering neighbors with too low common points, threshold=50...
2021-02-27 08:56:28 avg neighbors before filtering: 48.1472 (62% filtered out)
2021-02-27 08:56:28 limiting neighbors to 40 best...
2021-02-27 08:56:28 avg neighbors before limiting: 18.1963 (0% limited out)
2021-02-27 08:56:28 neighbors number min/1%/10%/median/90%/99%/max: 2, 4, 5, median=20, 31, 34, 34
2021-02-27 08:56:28 cameras info prepared in 0.549 s
2021-02-27 08:56:28 saved cameras info in 0.026
2021-02-27 08:56:28 Partitioning 163 cameras...
2021-02-27 08:56:28 number of mini clusters: 13
2021-02-27 08:56:28 4 groups: avg_ref=40.75 avg_neighb=30.25 total_io=174%
2021-02-27 08:56:28 max_ref=50 max_neighb=43 max_total=93
2021-02-27 08:56:28 cameras partitioned in 0.002 s
2021-02-27 08:56:28 saved depth map partition in 0.005 sec
2021-02-27 08:56:28 loaded cameras info in 0.06
2021-02-27 08:56:28 loaded depth map partition in 0 sec
2021-02-27 08:56:28 already partitioned (49<=50 ref cameras, 15<=200 neighb cameras)
2021-02-27 08:56:28 group 1/1: preparing 64 cameras images...
2021-02-27 08:56:28 point cloud loaded in 0.006 s
2021-02-27 08:56:29 Found 1 GPUs in 0.988 sec (CUDA: 0.002 sec, OpenCL: 0.986 sec)
2021-02-27 08:56:30 Using device: AMD Radeon HD 7700 Series (Capeverde), 10 compute units, free memory: 1998/2048 MB, OpenCL 1.2
2021-02-27 08:56:30   driver version: 3188.4, platform version: OpenCL 2.1 AMD-APP (3188.4)
2021-02-27 08:56:30   max work group size 256
2021-02-27 08:56:30   max work item sizes [1024, 1024, 1024]
2021-02-27 08:56:30   max mem alloc size 1523 MB
2021-02-27 08:56:30   wavefront width 64
2021-02-27 08:56:30 Using device: CPU Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz (using 3/8)
2021-02-27 08:56:31 Building kernels for AMD Radeon HD 7700 Series (Capeverde)...
2021-02-27 08:56:32 Device 1
2021-02-27 08:56:32    Program build log:
2021-02-27 08:56:32 Error: Undeclared function index 1028
2021-02-27 08:56:32
2021-02-27 08:56:32
2021-02-27 08:56:32 Failed to compile binary dumped to C:/Users/David/AppData/Local/Agisoft/Metashape/cache/kernel_cache/pm_undistort_templated4098AMD Radeon HD 7700 Series (Capeverde)_FAILED
2021-02-27 08:56:34 Finished processing in 6.788 sec (exit code 0)
2021-02-27 08:56:34 Error: ciErrNum: CL_BUILD_PROGRAM_FAILURE (-11) at line 1087

David Cockey

  • Full Member
  • ***
  • Posts: 207
    • View Profile
Re: CL_BUILD_PROGRAM_FAILURE (-11) at line 1087
« Reply #6 on: February 27, 2021, 05:15:45 PM »
Uninstalled Agisoft Metashape 1.7.1 Windows Standard Edition

Installed Agisoft Metashape 1.6.6 Windows Standard Edition and now works.

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14010
    • View Profile
Re: CL_BUILD_PROGRAM_FAILURE (-11) at line 1087
« Reply #7 on: February 27, 2021, 06:29:17 PM »
Hello David,

Thank you for additional information. We were able to reproduce the issue on HD7900 series card and will be checking, how the problem can be fixed on our side. I will notify you as soon as we have any solution.

Depth maps in 1.7 version are generated in a different way than in version 1.6 and older, that's why you are not observing this problem in 1.6.6 version.
Best regards,
Alexey Pasumansky,
Agisoft LLC