Forum

Author Topic: GeoTIFF Problems with several layers  (Read 273 times)

DavidD

  • Newbie
  • *
  • Posts: 19
    • View Profile
GeoTIFF Problems with several layers
« on: April 15, 2021, 03:08:21 PM »
I have a RGB+NIR orthomosaic and when I export it, it seams to have some faulty  encoding:

Every further processing step in gdal resports:
TIFFReadDirectory:Sum of Photometric type-related color channels and ExtraSamples doesn't match SamplesPerPixel. Defining non-color channels as ExtraSamples.

So there seems to be a problem in how the image is stored.
I'm running 1.7.3 build 12136

Best, David

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 12742
    • View Profile
Re: GeoTIFF Problems with several layers
« Reply #1 on: April 15, 2021, 08:13:24 PM »
Hello David,

Do you observe the problem when exporting orthomosaic with alpha-channel option enabled?
Best regards,
Alexey Pasumansky,
Agisoft LLC

DavidD

  • Newbie
  • *
  • Posts: 19
    • View Profile
Re: GeoTIFF Problems with several layers
« Reply #2 on: April 16, 2021, 12:26:02 PM »
Hi Alexey,
yes the alpha channel is enabled in the export.

Best, David

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 12742
    • View Profile
Re: GeoTIFF Problems with several layers
« Reply #3 on: April 16, 2021, 02:25:05 PM »
Hello David,

And if you disable alpha-channel, is there still any issue with the post-processing?
Best regards,
Alexey Pasumansky,
Agisoft LLC