Forum

Author Topic: Orientating DEMs so that they are all the same when they are exported  (Read 323 times)

PollyT

  • Newbie
  • *
  • Posts: 6
    • View Profile
Hello,

I'm creating DEMs using images taken from a go-pro camera. Its very small scale (cm scale) so to make sure it is scaled correctly I've been using the following steps:

- switch the coordinate system in the Reference pane settings dialog to "Local coordinates (m)",
- uncheck all cameras and markers in the Reference pane,
- right-click on the chunk's label in the Workspace pane and select "Reset transform" option from the context menu,
- input the scale bar distances to the source values tab of the Reference pane,
- check on the scale bars in the Reference pane,
- press Update button on the pane's toolbar.

The DEMs are all of the same thing as I'm tracking changes through time so I need them to all be orientated the same way. When I export them and then import them onto GIS some are not orientated the same way and are not quite the same scale, even though I have scaled them all the same. How do I rectify this?

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 12851
    • View Profile
Hello PollyT,

DEM and Orthomosaic should be rebuilt after any changes to the model referencing have been applied (providing that you need these changes to be reflected in DEM or orthomosaic).
Best regards,
Alexey Pasumansky,
Agisoft LLC

PollyT

  • Newbie
  • *
  • Posts: 6
    • View Profile
I have the model oriented and scaled as I want it (attached screenshot) before I create the DEM but then when I create the DEM the orientation is not the same/as I want it (second screenshot). How do I rectify this?

Thanks!

Paulo

  • Hero Member
  • *****
  • Posts: 638
    • View Profile
Hey PollyT,

the reason is your shown model view is not Top down. Press 7 (top view) and  5 (orthographic projection) and you will see the model exactly as in  DEM....

You can always use Rotate Object to rotate the model to the desired view before generating DEM...
« Last Edit: May 12, 2021, 01:09:08 AM by Paulo »
Best Regards,

Paul Pelletier

PollyT

  • Newbie
  • *
  • Posts: 6
    • View Profile
Hi Paulo,

Thanks for highlighting the 7 and 5 keys. Even when I use these or the Rotate Object tool to get it to the desired view the DEM that's generated is still orientated differently to the model...

Maybe it is a scaling issue?

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 12851
    • View Profile
Hello PollyT,

If the coordinate information and scale bar input is correct in the Reference pane, please press Update button on the Reference pane toolbar to apply this information. Then DEM should be re-built.

You may also need to consider building mesh using Arbitrary mode from the depth maps, as it seems you have generated it in Height Field mode and have quite a lot of unexpected "spikes" on the model.
Best regards,
Alexey Pasumansky,
Agisoft LLC