Forum

Author Topic: Project was from older version carried over to the New Version issues ?  (Read 334 times)

PROBERT1968

  • Sr. Member
  • ****
  • Posts: 314
  • Hello !
    • View Profile
Alexy,

I am very puzzled here with all the blue flags I have here on my Photos view...

I worked on this project from a older version a couple of years ago and it was done...

Now I am revive it back and I am working on it again this time the newer version with the basemap.

Whenever I click on that photo with blue flag, I see none blue flag  just green ones..

Is there a bug I am seeing ?

Here are the screen of examples :

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 12857
    • View Profile
Hello PROBERT1968,

If you execute the following code while at least one camera is selected, it will print out the console the information about the markers which have projections on the selected images and their pinned/unpinned status:

Code: [Select]
import Metashape
chunk = Metashape.app.document.chunk
for camera in chunk.cameras:
if not camera.selected:
continue
for marker in chunk.markers:
if camera in marker.projections.keys():
coord = marker.projections[camera].coord
pinned = marker.projections[camera].pinned
valid = marker.projections[camera].valid
if pinned:
pinned = "pinned (green flag)"
else:
pinned = "unpinned (blue flag)"
if not valid:
valid = "blocked/"
else:
valid =""
output = "{:s}\t{:s}\t{:.3f}\t{:.3f}\t{:s}{:s}\n".format(camera.label, marker.label, coord.x, coord.y, valid, pinned)
print(output)
print("script finished")
Best regards,
Alexey Pasumansky,
Agisoft LLC

PROBERT1968

  • Sr. Member
  • ****
  • Posts: 314
  • Hello !
    • View Profile
Thanks for the script I grab it and ran with it.. 

At first it showed nothing but realized it only prints to the console screen..

So now what do I need to do with ?

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 12857
    • View Profile
Hello PROBERT1968,

You can run this script for bov10_34 and see, which unpinned markers are listed and which coordinates do they have.

Please also check, if you have any shapes with attached markers (enable View Shapes in Photo view mode) - maybe they are related to the blued flags that you observe.
Best regards,
Alexey Pasumansky,
Agisoft LLC

PROBERT1968

  • Sr. Member
  • ****
  • Posts: 314
  • Hello !
    • View Profile
I think it is possible that I may have accidentally hit the attach markers with the shapes and the markers  , do you think that cause this ?

If that is the case then how do I unattached the markers from it ?

I  selected all of the photos and ran with the script you gave it to me shows a lot of more than that.

I did review and I realized it is right but there are a few that I am not sure of...


Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 12857
    • View Profile
Hello PROBERT1968,

In the version 1.7.3 (currently available as pre-release) there's a Detach Markers command in the shape context menu.

If the script gives you empty labels for some markers, they are likely related to the shapes.
Best regards,
Alexey Pasumansky,
Agisoft LLC

PROBERT1968

  • Sr. Member
  • ****
  • Posts: 314
  • Hello !
    • View Profile
Good to hear that you are going to add that feature !

Ok

it looks like my orthomosaic ran fine even though this issues I had...

When we get a update for that new version I will then bring it back and see what happens..

Thanks !