Forum

Author Topic: Texture blending fails to choose appropriate GPU  (Read 163 times)

Lazar Obradovic

  • Newbie
  • *
  • Posts: 7
    • View Profile
Texture blending fails to choose appropriate GPU
« on: April 06, 2022, 11:09:49 PM »
I have multipe dGPUs in the system (1x iGPU + 2x dGPU).
Both dGPUs are enabled for processing in Preferences /  GPU, but both are ignored during texture blending because one of them doesn't have enough VRAM, even though other GPU is good enough:

Code: [Select]
Found 3 GPUs in 0.001 sec (CUDA: 0 sec, OpenCL: 0.001 sec)
Using device: NVIDIA GeForce GTX 1070, 15 compute units, free memory: 7048/8191 MB, compute capability 6.1
  driver/runtime CUDA: 11060/10010
  max work group size 1024
  max work item sizes [1024, 1024, 64]
Using device: Quadro P520, 3 compute units, free memory: 1653/2047 MB, compute capability 6.1
  driver/runtime CUDA: 11060/10010
  max work group size 1024
  max work item sizes [1024, 1024, 64]
  got device properties in 0 sec, free memory in 0.752 sec
Found device NVIDIA GeForce GTX 1070 driver version 512.15.0.0, API version: 1.3.194, location 7::0
Found device Intel(R) UHD Graphics 620 driver version 1655906, API version: 1.2.196, location 4294967295::4294967295
Only NVIDIA and AMD devices are currently supported
Found device Quadro P520 driver version 512.15.0.0, API version: 1.3.194, location 60::0
[...]
Collecting memory requests...
Allocating memory requests...
Estimated required video memory: 2301 MB
Estimated device memory: total 1983 MB, used 116 MB, available 1686 MB
Cannot use GPU. Reason: Not enough memory on device
Performing blending on CPU...

Notice how iGPU is also reported (and warned!), even when it's disabled in the Preferences / GPU.

If I manually disable poorer dGPU and leave only more powerful one, blending selection decides to use GPU.

My expectation:
- disabled GPUs will be fully ignored (not even reported or warned) - cosmetic reasons.
- any of the matching enabled GPUs will be used, possibly in parallel and the ones that do not fit the criteria will be ignores - real issue here.
- CPU will be used only if no matching GPUs are found and only if "use CPU for processing" is enabled in Preferences - prevent long running tasks due to misconfiguration.

You can consider adding additional setting ("Allow CPU usage for texture blending... ") but that's a feature request :)

Hope this helps.