Forum

Author Topic: V. 1.7.3 alignment failure  (Read 1960 times)

ajalandoni

  • Newbie
  • *
  • Posts: 4
    • View Profile
V. 1.7.3 alignment failure
« on: June 18, 2021, 11:26:18 AM »
I upgraded to 1.7.3 to have better animation controls of a built model. The animation worked fine but now I cannot align any datasets, even ones that I have previously aligned successfully.

Any help will be much appreciated!

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14004
    • View Profile
Re: V. 1.7.3 alignment failure
« Reply #1 on: June 18, 2021, 02:09:28 PM »
Helllo ajalandoni,

Can you please share any processing log related to the failed alignment operation?
Best regards,
Alexey Pasumansky,
Agisoft LLC

ajalandoni

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: V. 1.7.3 alignment failure
« Reply #2 on: June 21, 2021, 02:21:22 AM »
Hi Alexey,

Thanks for your prompt response. I'm attaching the log.

I copied a chunk that had been fully processed to a textured model before the update. After resetting alignment, it won't realign.

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14004
    • View Profile
Re: V. 1.7.3 alignment failure
« Reply #3 on: June 21, 2021, 12:03:02 PM »
Hello ajalandoni,

What if you set any fixed value for key point limit instead of using unlimited value ("zero"), does it make any difference?
Best regards,
Alexey Pasumansky,
Agisoft LLC

ajalandoni

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: V. 1.7.3 alignment failure
« Reply #4 on: June 21, 2021, 12:21:55 PM »
Yes, that works! Why is that? What's the maximum value I can assign it now?

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14004
    • View Profile
Re: V. 1.7.3 alignment failure
« Reply #5 on: June 21, 2021, 01:22:06 PM »
Hello ajalandoni,

It seems to be a bug in 1.7.3 version, so to simulate the behavior with zero value, you can just use some very high value for the key point count if you need it for any reason, although such approach usually leads to the big number of tie points of low confidence.

The problem with zero value should be fixed in 1.7.4 version update.
Best regards,
Alexey Pasumansky,
Agisoft LLC

ajalandoni

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: V. 1.7.3 alignment failure
« Reply #6 on: June 21, 2021, 02:26:40 PM »
Is it better to limit the key points from the start? My workflow is usually to set key point and tie points to infinity and then use gradual selection to get rid of low confidence points.