Forum

Author Topic: 1.8 beta crashing a lot  (Read 674 times)

bgreenstone

  • Jr. Member
  • **
  • Posts: 63
    • View Profile
1.8 beta crashing a lot
« on: September 23, 2021, 06:36:29 PM »
I've had the 1.8 pre-release crash on my about 50% of the time when I've tried building a mesh using the depth map method.  I've been out of the room each time it crashed, so when I walk in I just see the crash reporter dialog.  Therefore, I don't know if it crashed during depth map generation, after it, during mesh building, or what.  But I submitted the crash each time.

It also still locks up my Mac Pro sometimes during depth map generation, but all versions of MetaShape have been doing that, so nothing new there.

-Brian

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13221
    • View Profile
Re: 1.8 beta crashing a lot
« Reply #1 on: September 27, 2021, 04:47:12 PM »
Hello Brian,

Which GPU models you have installed in the system and which macOS version is used?

Also do you observe any similar issues, if the depth maps computation is run on CPU only (you can check it on rather small project for a quick test)?
Best regards,
Alexey Pasumansky,
Agisoft LLC

bgreenstone

  • Jr. Member
  • **
  • Posts: 63
    • View Profile
Re: 1.8 beta crashing a lot
« Reply #2 on: September 27, 2021, 05:49:18 PM »
My Mac Pro has two AMD Radeon HD - FirePro D300 GPU's.  I will try running a CPU-only scan overnight and see what happens.  I'm running Mac OS 11.6   Metashape 1.7.3 is still running fine - just the occasional system freeze during depth map generation that I reported to you earlier this year.

Thanks,

-Brian

bgreenstone

  • Jr. Member
  • **
  • Posts: 63
    • View Profile
Re: 1.8 beta crashing a lot
« Reply #3 on: September 28, 2021, 09:50:21 PM »
It seems to crash a lot less if I use High quality during Depth Map generation.  Crashes almost every time with Ultra quality.
« Last Edit: September 29, 2021, 02:28:01 AM by bgreenstone »

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13221
    • View Profile
Re: 1.8 beta crashing a lot
« Reply #4 on: September 29, 2021, 07:21:41 PM »
Thanks, Brian, we are checking the crashes, which happens in Metashape 1.8 on macOS.
Best regards,
Alexey Pasumansky,
Agisoft LLC

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13221
    • View Profile
Re: 1.8 beta crashing a lot
« Reply #5 on: October 14, 2021, 05:20:56 PM »
Hello Brian,

Can you please check, if the crashes are gone in pre-release of 1.8.0 build 13257 published today?

If there are still any crashes, please submit the crash report.
Best regards,
Alexey Pasumansky,
Agisoft LLC

bgreenstone

  • Jr. Member
  • **
  • Posts: 63
    • View Profile
Re: 1.8 beta crashing a lot
« Reply #6 on: October 14, 2021, 05:25:53 PM »
I will runs some tests this morning, thanks.  Does the new build fix any of the issues with the blobby layer of geometry being generated on the underside of everything?

-Brian

bgreenstone

  • Jr. Member
  • **
  • Posts: 63
    • View Profile
Re: 1.8 beta crashing a lot
« Reply #7 on: October 14, 2021, 07:47:55 PM »
Well, good news & bad news:

GOOD NEWS:  I ran 3 chunks on Ultra Quality and they all executed perfectly with no crashing.  I'll run some more just to be sure, but previously there's almost no way it would have made it through 3 without crashing.

BAD NEWS:  The geometry that it is generating is still unusable.  All 3 of the resulting meshes had that same blobby excess geometry on the underside of the mesh, and since most of those blobs were physically connected to the valid geometry there is no way to remove them.  Therefore, I still cannot use this version :(

Thanks,

-Brian