Forum

Author Topic: [SOLVED] Error: Kernel failed: invalid device pointer (17) at lline 99  (Read 1330 times)

2bForgotten

  • Newbie
  • *
  • Posts: 17
    • View Profile
Hi @Alex Pasumansky,

When trying to refine a mesh, I keep running into this error: Kernel failed: invalid device pointer (17) at line 99.

As I suspected it could have to do with the Nvidia drivers for the two RTX 2080 cards in the workstation, I tried both
- Studio driver v472.12
- Game ready driver v496.13
Both to no avail.

Also tried to run with only 1 RTX 2080. All in vain.

Machine is Windows 10, dual Xeon E5-2678 v3 @2.50 GHz, 128 GB RAM.
Agisoft version is 1.7.5 build 13229 64bit

Last lines in the log file:
2021-10-22 19:25:02 Stage #2 out of 2
2021-10-22 19:25:03 Faces: 4832973, Vertices: 2418981
2021-10-22 19:25:03 Memory required on each device: 57 Mb + 1013 Mb = 1071 Mb
2021-10-22 19:25:03 Subdividing mesh...
2021-10-22 19:25:55 Faces: 15424940, Vertices: 7715781
2021-10-22 19:25:55 Memory required on each device: 258 Mb + 3236 Mb = 3494 Mb
2021-10-22 19:25:56 Using device 'NVIDIA GeForce RTX 2080' in concurrent. (1 times)
2021-10-22 19:25:56 Loading photos...
2021-10-22 19:25:57 Finished processing in 295.559 sec (exit code 0)
2021-10-22 19:25:57 Error: Kernel failed: invalid device pointer (17) at line 99

Please inform me how to solve this error.

***EDIT [SOLVED]***
Although I searched this forum before posting, I must have overlooked this post that solved the issue by switching to OpenGL.
https://www.agisoft.com/forum/index.php?PHPSESSID=98t8gs5cgnv4rgj2pmp1281ie3&topic=13591.msg60098#msg60098

Kind regards,
« Last Edit: October 22, 2021, 09:03:10 PM by 2bForgotten »

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14003
    • View Profile
Re: Error: Kernel failed: invalid device pointer (17) at lline 99
« Reply #1 on: October 22, 2021, 09:01:47 PM »
Hello 2bForgotten,

Looks like you are observing the similar problem as reported before:
https://www.agisoft.com/forum/index.php?topic=13591.0

The identical CUDA cards cause the problem for Refine Mesh operation. As a current workaround you can switch to OpenCL implementation by setting main/gpu_enable_cuda tweak to False value.
Best regards,
Alexey Pasumansky,
Agisoft LLC

2bForgotten

  • Newbie
  • *
  • Posts: 17
    • View Profile
Re: Error: Kernel failed: invalid device pointer (17) at lline 99
« Reply #2 on: October 22, 2021, 09:08:47 PM »
Hello 2bForgotten,

Looks like you are observing the similar problem as reported before:
https://www.agisoft.com/forum/index.php?topic=13591.0


Hi Alex,

Thank you so much for the fast response. I found it while you must have been typing  ;)

Regards,