Forum

Author Topic: How can I install numpy in Agisoft ?  (Read 3687 times)

lyhour

  • Newbie
  • *
  • Posts: 41
    • View Profile
How can I install numpy in Agisoft ?
« on: October 25, 2021, 02:56:07 PM »
Excuse me everyone! I want to use numpy in my python script in Agisoft. When I run it say that the numpy is not installed. I have been installed in my computer and used it so far in different environment. I try to copy from the site-packages to Agisoft directory like : C:\Program Files\Agisoft\Metashape Pro\python\Lib. But it still error. I am stuck of this problem. It would be better if any give me suggestion to solve this problem. Thank you very much.
« Last Edit: October 25, 2021, 03:12:16 PM by lyhour »

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14927
    • View Profile
Re: How can I install numpy in Agisoft ?
« Reply #1 on: October 25, 2021, 03:53:03 PM »
Hello lyhour,

Please check the following article, which describes, how to install the external module to Metashape Python:
https://agisoft.freshdesk.com/support/solutions/articles/31000136860-how-to-install-external-python-module-to-metashape-professional-package
Best regards,
Alexey Pasumansky,
Agisoft LLC

lyhour

  • Newbie
  • *
  • Posts: 41
    • View Profile
Re: How can I install numpy in Agisoft ?
« Reply #2 on: October 26, 2021, 05:39:21 AM »
Dear Alexey,
Thank  you very much for you kindly response. I have been tried your link. It shows the problem as in the attachment file. What should I do to solve it.

Best Regards,
LYHOUR

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14927
    • View Profile
Re: How can I install numpy in Agisoft ?
« Reply #3 on: October 26, 2021, 12:24:22 PM »
Hello lyhour,

Can you please try to run the same command using administrator privileges?
Best regards,
Alexey Pasumansky,
Agisoft LLC

lyhour

  • Newbie
  • *
  • Posts: 41
    • View Profile
Re: How can I install numpy in Agisoft ?
« Reply #4 on: October 26, 2021, 03:21:45 PM »
Dear Alexey,
I already did it. I have been used numpy many times in my python version 3.7. when I installed using the command as in the link you gave me, I said that it already installed as show in the attachment 2. I noticed that the Agisoft I am using is in python 3.8. Does it related to this problem ? I will shows you the error when I am running the script as show in the attachment 1. Thank you very much.