Forum

Author Topic: Ripples appearing in built Mesh  (Read 515 times)

skcotterell

  • Newbie
  • *
  • Posts: 2
    • View Profile
Ripples appearing in built Mesh
« on: January 22, 2022, 01:34:54 AM »
Hey everyone,

I've been having some issues with 'ripples' appearing my model after building the Mesh. Making it appear almost 3D printed on one axis. This is the second object this has happend with, however the I wont have access to the other until until next week.

My dense point cloud i'm very happy with, and as a sanity check i ran it through RC and didn't get any ripples so I'm not sure what setting is causing this effect?

Any help would be greatly appreciated. Thanks
« Last Edit: January 22, 2022, 01:37:09 AM by skcotterell »

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13730
    • View Profile
Re: Ripples appearing in built Mesh
« Reply #1 on: January 23, 2022, 08:33:26 PM »
Hello skcotterell,

Can you also share the screenshot of the source dense cloud that you are using for the mesh generation?

Additionally please check, if you get better mesh reconstruction results with the interpolation enabled, or even when using the depth maps as a source in Build Mesh dialog.
Best regards,
Alexey Pasumansky,
Agisoft LLC

frmgsft

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: Ripples appearing in built Mesh
« Reply #2 on: January 26, 2022, 10:47:27 PM »
I got the same issue with 1.8.1 RC
Ripples show up on meshes reconstructed with 'Use strict volumetric masks' enabled. Turning this option off brings a smooth/correct geometry.
Also, density of the mesh reconstructed using masks is way higher (like 1117k vs 493k faces).

Andreas1206

  • Newbie
  • *
  • Posts: 23
    • View Profile
Re: Ripples appearing in built Mesh
« Reply #3 on: January 27, 2022, 10:33:45 AM »
Hello,

I'm experiencing the same issue when building the mesh from a dense cloud - also with interpolation enabled and strict masks disabled. It does not happen on the mesh based on depth maps, but I sometimes prefer working with the dense cloud, because filtering options before calculating the mesh are usefull.

best regards,

Andreas

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13730
    • View Profile
Re: Ripples appearing in built Mesh
« Reply #4 on: January 28, 2022, 08:20:04 PM »
Hello frmgsft,

How many strict masks do you have in that project, how tight are those masks to the actual object?


Hello Andreas,

Can you provide the screenshot of the same scene in the dense cloud view and specify the depth maps quality used? If you can share the project, which can be used for analysis, where the issue can be reproduced, please send it to support@agisoft.com.
Best regards,
Alexey Pasumansky,
Agisoft LLC