Forum

Author Topic: Metashape 1.8.X not using all available GPUs  (Read 552 times)

RHenriques

  • Full Member
  • ***
  • Posts: 208
    • View Profile
Metashape 1.8.X not using all available GPUs
« on: January 24, 2022, 06:43:47 PM »
Hi

Today I've opened version 1.8.0 and, contrary to vs 1.7.6, the latest version cannot see all the available GPUs.
Cuda is enabled. Version 1.7.6 is behaving normally.
See attached screen captures.
Best Regards


Zevram

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Metashape 1.8.X not using all available GPUs
« Reply #1 on: January 25, 2022, 12:11:49 AM »
agreed; I have noticed the same issue

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13729
    • View Profile
Re: Metashape 1.8.X not using all available GPUs
« Reply #2 on: January 25, 2022, 12:49:23 PM »
Hello Renato,

Starting from Metashape 1.8 for macOS versions CUDA is no longer supported, as announced last Summer, NVIDIA graphic cards will work using OpenCL. You may keep both 1.7.8 and 1.8 versions installed on your system and use 1.7.6 for intensive GPU based processing.
As far as I remember from out previous communication, clinfo utility is also confused and identifies only one NVIDIA card, which means that the might be some flaw in the driver installed. However, if you have a possibility to check, whether two different NVIDIA cards are properly recognized or are also merged to the single OpenCL device, please let me know.

Hello Zevram,

What macOS version do you have installed on your system and which GPU models are available?
Best regards,
Alexey Pasumansky,
Agisoft LLC

RHenriques

  • Full Member
  • ***
  • Posts: 208
    • View Profile
Re: Metashape 1.8.X not using all available GPUs
« Reply #3 on: January 25, 2022, 09:59:41 PM »
Hi Alexey

You are right. I've forgot that decision. Harsh one...
OpenCL is not working, as you might remember, because is messes the 2 GPU's and only considers one. The other one is totally skipped, rendering it useless.
I'll try to keep a 1.7.8 version handy.
Meanwhile I've build another machine, with an AMD 6800XT and an AMD6900XT, also using MacOS and it's a lot faster that my previous setup.
Best regards.