Forum

Author Topic: Installation issue on Linux (Rocky or Centos 8)  (Read 219 times)

urielr

  • Newbie
  • *
  • Posts: 3
    • View Profile
Installation issue on Linux (Rocky or Centos 8)
« on: August 18, 2022, 02:31:20 PM »
Hi ,

I am getting the following error :


Got keys from plugin meta data ("xcb")
QFactoryLoader::QFactoryLoader() checking directory path "/root/metashape/platforms" ...
loaded library "/root/metashape/plugins/platforms/libqxcb.so"
could not connect to display localhost:10.0
Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: offscreen, xcb.

./metashape.sh: line 19:   306 Aborted                 (core dumped) "



I ran the executable with QT_DEBUG_PLUGINS=1 ./metashape.sh  option as adviced by other posts in this forum .
can you please tell me how to troubleshoot this issue ?
 also attached the entire output I got after running "QT_DEBUG_PLUGINS=1 ./metashape.sh"

urielr

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Installation issue on Linux (Rocky or Centos 8)
« Reply #1 on: August 22, 2022, 11:28:19 AM »
Hi,

fixed by installing mesa-dri-drivers

urielr

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Installation issue on Linux (Rocky or Centos 8)
« Reply #2 on: August 22, 2022, 11:36:41 AM »
Another question please.

is centos 7 supported by your software ?

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13917
    • View Profile
Re: Installation issue on Linux (Rocky or Centos 8)
« Reply #3 on: August 22, 2022, 01:29:43 PM »
Hello urielr,

Most likely you wouldn't be able to run Metashape 1.8 on CentOS 7, but older Metashape versions should work on that OS.
Best regards,
Alexey Pasumansky,
Agisoft LLC