Forum

Author Topic: Haze on colorcharts and rulers  (Read 976 times)

renevg

  • Newbie
  • *
  • Posts: 39
    • View Profile
Haze on colorcharts and rulers
« on: February 23, 2022, 01:18:06 AM »
I've taken 3 series of photographs of this object. Each time there was 1 colorchart included. It's on a turntable with the ruler around the object. What I don't understand is why the rulers and the colorcharts aren't clear. There is some kind of haze on top of them.  I thought it might be the white from the turntable projected onto the mesh.  After I noticed this I generated masks in each photograph and did it all over again, but without any luck. Can anyone tell me please what is going on? see attachments.
Thanks
René

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14765
    • View Profile
Re: Haze on colorcharts and rulers
« Reply #1 on: February 24, 2022, 08:49:28 PM »
Hello René,

There might be some cameras, chosen as optimal for the rulers/charts texturing, which include those objects in out of focus range.

If you have certain photos, where these objects are clearly visible without any blur, you can leave the rulers and charts unmasked on those few images only and apply the masks to them on all the other images.
Best regards,
Alexey Pasumansky,
Agisoft LLC

renevg

  • Newbie
  • *
  • Posts: 39
    • View Profile
Re: Haze on colorcharts and rulers
« Reply #2 on: February 24, 2022, 09:23:08 PM »
I'm going to try that, but I still think something else is going on. because I use 3 groups of photographes It looks like the texture of the table is coming through. I made a texture with blending mode disabled and this is what it looks like.

renevg

  • Newbie
  • *
  • Posts: 39
    • View Profile
Re: Haze on colorcharts and rulers
« Reply #3 on: February 25, 2022, 12:45:22 AM »
Okay so I spent couple of hours masking 336 photographes and that worked! white haze is gone. I didn't mask focus but pure the objects. I masked out the table. Good to know for future projects.
thanks
René

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14765
    • View Profile
Re: Haze on colorcharts and rulers
« Reply #4 on: February 25, 2022, 02:45:36 PM »
Hello René,

If such kind of projects are typical for your work, you may consider the following masking approach:
- after building the model similar to the one you have on the screenshot (object + rulers and charts), duplicate it in the Workspace pane and remove all mesh components related to the rulers, charts and any other background elements,
- run File Menu -> Import Masks procedure and choose "From Model" option - it will create masks for all the aligned cameras, based on the existing mesh model,
- then manually review the images, where the charts and rulers are captured in sharp details and unmask them there,
- switch the default mesh model in the Workspace pane to the original model,
- rebuild the texture with the desired parameters.
Best regards,
Alexey Pasumansky,
Agisoft LLC

renevg

  • Newbie
  • *
  • Posts: 39
    • View Profile
Re: Haze on colorcharts and rulers
« Reply #5 on: February 25, 2022, 03:26:53 PM »
Hi Alexey, I did use Masks from model, also when I ran into the problems. Last night I retouched the masks manually. What I didn't try was deleting (or hiding) some mesh, so that's what I'm going to try next time. This is a whole new way of masking for me.  Thanks!
René