Forum

Author Topic: bundler output (camera) and 3d model don't seem to be aligned  (Read 696 times)

ttsesm

  • Newbie
  • *
  • Posts: 9
    • View Profile
Hi,

I am using Metashape to successfully build my 3d model from given images. Thereafter, I am exporting the cameras as "Bunlder (*.out)" file and the model as an .obj file.

Then I am loading both in Meshlab in order to visualize the alignment in Raster mode but what I notice is that there is a miss-alignment as shown in the attached image.

Any way/idea how to correct this, since it really ruins my next processing steps.

Thanks.

« Last Edit: March 21, 2022, 06:57:03 PM by ttsesm »

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14012
    • View Profile
Re: bundler output (camera) and 3d model don't seem to be aligned
« Reply #1 on: March 21, 2022, 08:25:19 PM »
Hello ttsesm,

Could it be due to the lack of distortion model information saved in Bundler format? Unless I am mistaken, bundler.out stores only F (focal length) and K1, K2 coefficients.

You can try to export undistorted images and use them instead of original images and check, if it makes any difference.
Best regards,
Alexey Pasumansky,
Agisoft LLC

ttsesm

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: bundler output (camera) and 3d model don't seem to be aligned
« Reply #2 on: March 22, 2022, 01:11:01 PM »
Hi Alexey,

Thanks for the feedback. Can you give me some guidance how to do that. I've tried the File --> Export --> Convert Images option but it doesn't seem to change much.

Or if there is any other way to correctly load my model with the aligned images in Meshlab.

ttsesm

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: bundler output (camera) and 3d model don't seem to be aligned
« Reply #3 on: March 22, 2022, 07:28:48 PM »
Ok, it seems that indeed the undistorted images make a difference. I've managed to save them through the python api, since from the gui I was not able to find the correct settings to save them.

ttsesm

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: bundler output (camera) and 3d model don't seem to be aligned
« Reply #4 on: March 23, 2022, 12:18:25 PM »
A small update, it seems that the usage of undistorted images helps on the overlaying of the images over the model but there is still something wrong  :-\. For example, the fist attached image is showing how the image overlays on the 3d model without using the undistorted image. The second attached image is after using the undistorted image. It seems to me that there is still some kind of problem in the camera params?

Is there any suggestion how I could fix this?