Forum

Author Topic: Bad texture issue  (Read 4345 times)

cyrilp

  • Jr. Member
  • **
  • Posts: 85
    • View Profile
Bad texture issue
« on: March 28, 2022, 03:09:03 PM »
Hi,

i have issues with the texture génération. Very often some parts of my model have bad blurry texture.

Here for exemple:

Metashape model (ultra high setting, 32x4k texture) (don't forget to select hd for textures in the tool box)
https://viewer.arskan.com/objects/share/6241a4b0eb315945a023cc04

Mac Photocatch model in raw settings:
https://viewer.arskan.com/objects/share/6241a450eb315945a023cbdf

Look around the mouth for example.


Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14927
    • View Profile
Re: Bad texture issue
« Reply #1 on: March 28, 2022, 05:43:39 PM »
Hello Cyril,

Can you share a sample dataset, where the problem can be reproduced to support@agisoft.com? Including Metashape project (with camera alignment and mesh) and source images.
Best regards,
Alexey Pasumansky,
Agisoft LLC

cyrilp

  • Jr. Member
  • **
  • Posts: 85
    • View Profile
Re: Bad texture issue
« Reply #2 on: March 29, 2022, 02:11:24 PM »
hi, i'm uploading the data right now (27go)

cyrilp

  • Jr. Member
  • **
  • Posts: 85
    • View Profile
Re: Bad texture issue
« Reply #3 on: April 01, 2022, 11:35:24 AM »
Hi Alex,

here is the link to download the data:

https://data2.gigascope.net/data/bm_ramses.rar

let me know

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14927
    • View Profile
Re: Bad texture issue
« Reply #4 on: April 01, 2022, 04:15:15 PM »
Hello Cyril,

Thank you for sharing the data, we were able to download the archive.
Best regards,
Alexey Pasumansky,
Agisoft LLC

cyrilp

  • Jr. Member
  • **
  • Posts: 85
    • View Profile
Re: Bad texture issue
« Reply #5 on: April 01, 2022, 04:55:49 PM »
Great ! i hope you'll find out why i'm getting bad results.

for comparison here is the model with good textures i'm getting with apple photocatch (remember to select hd textures).

The 3D model geometry is far better in metashape.

cyrilp

  • Jr. Member
  • **
  • Posts: 85
    • View Profile
Re: Bad texture issue
« Reply #6 on: April 03, 2022, 10:58:35 PM »

cyrilp

  • Jr. Member
  • **
  • Posts: 85
    • View Profile
Re: Bad texture issue
« Reply #7 on: April 05, 2022, 10:21:43 AM »
Hi Alexey, did you have some time to have a look ?

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14927
    • View Profile
Re: Bad texture issue
« Reply #8 on: April 05, 2022, 12:57:55 PM »
Hello Cyril,

We have got considerably better results using the following approach:
- generated masks based on the actual mesh model,
- estimated image quality for all cameras (with ignore masked regions option enabled),
- disabled cameras with image quality lower than 0.8,
- disabled cameras looking at the model from behind,
- rebuilt texture.

However, some areas with the blurred texture still can be found they are not that obvious as in the original model.


Generally, you may reconsider the image acquisition process: pay attention to focusing on the model's surface (some images are obviously out of focus), and try to avoid taking multiple images from the same camera location - if you are doing that, it is suggested to use calibrated nodal head and group the corresponding cameras to the "camera station".

Best regards,
Alexey Pasumansky,
Agisoft LLC

cyrilp

  • Jr. Member
  • **
  • Posts: 85
    • View Profile
Re: Bad texture issue
« Reply #9 on: April 09, 2022, 04:31:09 PM »
Hi,

Thanks for your answer, i will try this.

what do you mean disable cameras from behind ? do you mean i have to split my model in two and texture each of them disabling cameras from behind ?

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14927
    • View Profile
Re: Bad texture issue
« Reply #10 on: April 11, 2022, 08:02:48 PM »
Hello cyrilp,

In the provided project only one part of the model is present (only front part of the object of interest), so the cameras that are behind of the actual object couldn't help the texturing process. Thus it is better to disable them in advance (before building the texture for the front part of the model).
Best regards,
Alexey Pasumansky,
Agisoft LLC

DayGeckoArt

  • Jr. Member
  • **
  • Posts: 80
    • View Profile
Re: Bad texture issue
« Reply #11 on: April 11, 2022, 09:30:18 PM »
I'm learning drone 3D mapping and I've observed this issue. Agisoft chooses the photo closest to every given location geographically,  at least for creating the orthophoto. Since I mix higher and lower altitude photos, the higher ones often get chosen so I get blurry patches. I have to manually draw a polygon and then choose a different photo for that area. Disabling the more distant photos works, but not if you need parts of those images for coverage elsewhere in the model

cyrilp

  • Jr. Member
  • **
  • Posts: 85
    • View Profile
Re: Bad texture issue
« Reply #12 on: April 18, 2022, 02:24:23 PM »
I have to manually draw a polygon and then choose a different photo for that area
Hi, could you explain how this is done ?

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14927
    • View Profile
Re: Bad texture issue
« Reply #13 on: April 18, 2022, 02:31:23 PM »
I have to manually draw a polygon and then choose a different photo for that area
Hi, could you explain how this is done ?


Currently this works for orthomosaic only (cannot be applied to the texture): https://agisoft.freshdesk.com/support/solutions/articles/31000148853-orthomosaic-seamline-editing-patching-
Best regards,
Alexey Pasumansky,
Agisoft LLC