Forum

Author Topic: Unable to start on Linux (libtls error)  (Read 1230 times)

chippey

  • Newbie
  • *
  • Posts: 2
    • View Profile
Unable to start on Linux (libtls error)
« on: April 27, 2022, 07:53:14 PM »
So, Metashape 1.8.2 works fine on my linux installs (PopOS 20.04, and Ubuntu 20.04), but 1.8.3 no longer starts with the error:
symbol lookup error: /lib/x86_64-linux-gnu/libgnutls.so.30: undefined symbol: __gmpz_limbs_write

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13916
    • View Profile
Re: Unable to start on Linux (libtls error)
« Reply #1 on: April 28, 2022, 04:44:46 PM »
Hello chippey,

Please try to remove lib/libgmp.so.10 file from Metashape Pro directory.
Best regards,
Alexey Pasumansky,
Agisoft LLC

chippey

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Unable to start on Linux (libtls error)
« Reply #2 on: April 28, 2022, 11:01:43 PM »
That worked.  Thanks!