Forum

Author Topic: overexposed textures problem  (Read 274 times)

bassistas

  • Newbie
  • *
  • Posts: 12
    • View Profile
overexposed textures problem
« on: May 16, 2022, 01:26:52 AM »
Does anyone know why I'm getting such overexposed textures when I have grayscale laser scans imported in my project? If I disable the laser scans and create the texture with just the jpeg photos the texture is ok.
Also even if I import coloured laser scans I still get this black hole from each scan position which should not be there as there is texture information to cover that from the jpeg photos.

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13729
    • View Profile
Re: overexposed textures problem
« Reply #1 on: May 16, 2022, 02:08:45 PM »
Hello bassistas,

What color range (bit depth) the input photos and laser scans have?

As for the blank spots, I would suggest to mask out no-data regions on the images related to the laser scans prior to the texture generation stage.
Best regards,
Alexey Pasumansky,
Agisoft LLC

bassistas

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: overexposed textures problem
« Reply #2 on: May 16, 2022, 04:03:36 PM »
Hello bassistas,

What color range (bit depth) the input photos and laser scans have?

As for the blank spots, I would suggest to mask out no-data regions on the images related to the laser scans prior to the texture generation stage.

Hello, the jpegs are 8bit and the grayscale laser scans are 32bit. Could this be the problem? and what can I do?

I also tried to mask out the no-data regions from the laser scans and it solved the black hole issue but as this black area has the same height in the lower part of the image in all of my laser scans is it possible to mask out this automatically from all the scans with a script rather than doing it by hand for every single scan?

regards
« Last Edit: May 16, 2022, 04:05:52 PM by bassistas »

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13729
    • View Profile
Re: overexposed textures problem
« Reply #3 on: May 16, 2022, 04:11:32 PM »
Hello bassistas,

Quote
I also tried to mask out the no-data regions from the laser scans and it solved the black hole issue but as this black area has the same height in the lower part of the image in all of my laser scans is it possible to mask out this automatically from all the scans with a script rather than doing it by hand for every single scan?
You can create the mask for one image manually, export it and them import, applying to all selected scans.

Quote
the jpegs are 8bit and the grayscale laser scans are 32bit. Could this be the problem? and what can I do?
And what output do you expect - should the texture be 8-bit or 32-bit?
Best regards,
Alexey Pasumansky,
Agisoft LLC

bassistas

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: overexposed textures problem
« Reply #4 on: May 16, 2022, 04:15:46 PM »
I expect just 8bit output. So is there a problem if you combine 8bit images with 32bit laser scans tiff images? Should I convert my 8bit jpegs also to 32bit in order to avoid this "overexposed" effect?

bassistas

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: overexposed textures problem
« Reply #5 on: May 16, 2022, 06:27:36 PM »
Also I just tried now to disable the 8bit jpeg photos and try to create textures again with just the grayscale 32bit laser scans and it still produces the "overexposed" effect. So it seems there is some kind of a bug unless there is an option to adjust this somewhere.