Forum

Author Topic: Blending Textures not using GPU  (Read 476 times)

jinjamu

  • Newbie
  • *
  • Posts: 49
    • View Profile
Blending Textures not using GPU
« on: May 19, 2022, 08:10:14 AM »
Hi
I am using the latest Metashape (1.8.3 build 14331) on a windows laptop with AMD Rhyzen CPU and a 3080 Laptop GPU. I have also upgraded to the latest Nvidia driver version 512.77.  I did this in an effort to sold this problem but the problem remains.
When running textures I am getting the following
Code: [Select]
Found 2 GPUs in 0.483 sec (CUDA: 0.224 sec, OpenCL: 0.259 sec)
Using device: NVIDIA GeForce RTX 3080 Laptop GPU, 48 compute units, free memory: 14911/16383 MB, compute capability 8.6
  driver/runtime CUDA: 11060/10010
  max work group size 1024
  max work item sizes [1024, 1024, 64]
No GPUs selected. Proceeding on CPU.
Done "load_model" in 0
rendering 4 pages
calculating mesh connectivity... done in 3.716 sec
I know for sure that I have not always had this problem, which must have been introduced at a specific point when upgrading, either the Metashape version or the Nvidia driver.


Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13729
    • View Profile
Re: Blending Textures not using GPU
« Reply #1 on: May 19, 2022, 11:55:06 AM »
Hello jinjamu,

Do you have your NVIDIA GPU enabled in Metashape Preferences -> GPU tab?
Best regards,
Alexey Pasumansky,
Agisoft LLC

jinjamu

  • Newbie
  • *
  • Posts: 49
    • View Profile
Re: Blending Textures not using GPU
« Reply #2 on: May 19, 2022, 12:38:33 PM »
Yes, I checked that.

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13729
    • View Profile
Re: Blending Textures not using GPU
« Reply #3 on: May 19, 2022, 01:00:55 PM »
Hello jinjamu,

Do you see that GPU is used (according to Metashape log) during other processing operations, such as feature points detection, image matching, depth maps generation?

If so, please check, if there are any uncommon tweaks set up via Advanced preferences tab -> Tweaks dialog. Also please provide the starting lines from the Console pane related to the new Metashape instance start.
Best regards,
Alexey Pasumansky,
Agisoft LLC

jinjamu

  • Newbie
  • *
  • Posts: 49
    • View Profile
Re: Blending Textures not using GPU
« Reply #4 on: May 19, 2022, 03:20:58 PM »
Hi Alexey,
I cleared the log and restarted Metashape so what you see in the attached is the following:
1. Startup lines
2. Build mesh process where you can see the GPU is being used.  I aborted the process
3. Build texture process whereyou an see the same message I sent originally (GPU detected but not used).  In this case also I aborted the process
I can confirm that there are no tweaks at all in place
Thanks
John

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13729
    • View Profile
Re: Blending Textures not using GPU
« Reply #5 on: May 20, 2022, 04:16:39 PM »
Hello John,

Thank you for additional information.

It seems that Vulkan wan't able to identify the graphic cards properly, we'll try to implement a quick fix for the next version update to avoid unstable GPU detection by Vulkan.
Best regards,
Alexey Pasumansky,
Agisoft LLC

jinjamu

  • Newbie
  • *
  • Posts: 49
    • View Profile
Re: Blending Textures not using GPU
« Reply #6 on: May 20, 2022, 04:25:51 PM »
Thanks Alexey!  Looking forward to a quick fix (I'm a little stuck trying to conclude a project at the moment!)
Best regards
John

jinjamu

  • Newbie
  • *
  • Posts: 49
    • View Profile
Re: Blending Textures not using GPU
« Reply #7 on: June 16, 2022, 01:05:45 PM »
Hi Alexey, any news on this fix?
Thanks
John
« Last Edit: June 16, 2022, 01:29:35 PM by jinjamu »

jinjamu

  • Newbie
  • *
  • Posts: 49
    • View Profile
Re: Blending Textures not using GPU
« Reply #8 on: June 21, 2022, 10:41:27 PM »
Hi Alexy,
If a fix is not available yet, maybe you can kindly suggest a work around, maybe to revert back to a specific combination of versions of Metashape and graphics drivers that do not demonstrate this problem?
Thanks and regards
John

jinjamu

  • Newbie
  • *
  • Posts: 49
    • View Profile
Re: Blending Textures not using GPU
« Reply #9 on: June 23, 2022, 05:22:20 PM »
Hi Alexey!
Another gentle reminder regarding this thread. 
Thanks and regards
John

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13729
    • View Profile
Re: Blending Textures not using GPU
« Reply #10 on: June 23, 2022, 05:25:27 PM »
Hello John,

Does it help to disable integrated AMD Radeon(TM) Graphics in GPU tab of Metashape Preferences dialog (keep NVIDIA GPU enabled) and re-start Build Texture operation?

Also there seem to be a new NVIDIA driver released in the middle of June, so you can try to install it as well.
Best regards,
Alexey Pasumansky,
Agisoft LLC

jinjamu

  • Newbie
  • *
  • Posts: 49
    • View Profile
Re: Blending Textures not using GPU
« Reply #11 on: June 24, 2022, 02:49:15 PM »
Hi Alexey,

I tried disabling the AMD Radeon GPU, and updating to the last drived.  Problem is still there unfortunately.  I still get:

Using device: NVIDIA GeForce RTX 3080 Laptop GPU, 48 compute units, free memory: 14102/16383 MB, compute capability 8.6
  driver/runtime CUDA: 11070/10010
  max work group size 1024
  max work item sizes [1024, 1024, 64]
  got device properties in 0 sec, free memory in 37.858 sec
No GPUs selected. Proceeding on CPU.

Thanks

John

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13729
    • View Profile
Re: Blending Textures not using GPU
« Reply #12 on: June 24, 2022, 05:26:40 PM »
Hello John,

Have you tried to run any Vulkan tests on this machine? And whether GPU-Z shows a checkbox on Vulkan line for GeForce RTX 3080?

For me it looks like Vulkan is not properly recognized for some reason (as it is not installed).

Please create main/vk_verbose tweak and set its value to True, then try to run the texture blending operation and then provide the extended log related to the operation.
« Last Edit: June 24, 2022, 05:30:32 PM by Alexey Pasumansky »
Best regards,
Alexey Pasumansky,
Agisoft LLC

jinjamu

  • Newbie
  • *
  • Posts: 49
    • View Profile
Re: Blending Textures not using GPU
« Reply #13 on: June 26, 2022, 02:17:18 PM »
Hi Alexey,
Thanks for your suggestions. 
I am not so technical so please be patient, but the problem seems tpo be exactly as you are suggesting.
I downloaded and ran GPU-Z and Vulkan box is NOT ticked for the Nvidia processor
I tried a number of older Nvidia drivers and I tried the very last one also (each timewith a clean install) and at no point did Vulkan come up ticked
I downloaded the specific Vulkan RT drivers from the Vulkan site and installed those - same negative result
I also tried installing with AV disabled (I read somewhere that someone solved it this way) but still nothing
Vulkan drivers are not showing in the list of Windows apps (appwiz.cpl)
I'm attaching the extended log as requested https://drive.google.com/file/d/15Op8gYbbanmdLT6HzRa5-ja6OwGyUxPW/view?usp=sharing

I would really appreciate it if you had any ideas on how to get Vulkan working again!

Thanks and regards

John

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13729
    • View Profile
Re: Blending Textures not using GPU
« Reply #14 on: June 27, 2022, 03:57:09 PM »
Hello John,

As the problem does appear not only in Metashape, I could recommend to make a clean driver install. You can even try to remove NVIDIA driver completely using Display Driver Uninstaller utility, and then installing the latest available NVIDIA driver, downloaded directly from NVIDIA web-site, which appears to be 516.40:
https://www.nvidia.com/Download/driverResults.aspx/190349/en-us/
Best regards,
Alexey Pasumansky,
Agisoft LLC