Forum

Author Topic: Arrgg.. Can we get proper 0,0,0 and 0 rotation position for exporting to blender  (Read 1764 times)

gateway

  • Newbie
  • *
  • Posts: 30
    • View Profile
Hey everyone I know a lot of people struggle with this so I'm trying to find a solution that works for people exporting their objects from MS and cleaning them up in Blender.  I usually do this, and the object from MS comes in not at the 0,0,0 with no rotation which would be soooo ideal and save a lot of time because when you want to export out that object you can just do it from the center of the coordinate system instead of trying to figure out where in 3d space the object came in as.

I usually clean up in Blender then export back into MS to bake the higher quality textures back..

I may be missing something simple in MS, but man this has annoyed me for years.  Can we get something like Blender has that snaps the object to the center etc..

What are people doing and again sorry If i missed a simple export setting to do this. 

Bzuco

  • Full Member
  • ***
  • Posts: 144
    • View Profile
Hi, you can enable show grid in MS(menu Model - Show/Hide Items) and then manually rotate and translate model somewhere near [0,0,0](two crossed lines in grid)...it does not need to be perfectly aligned with XY plane. Then export 3d model to blender, do cleaning and export back to MS.

gateway

  • Newbie
  • *
  • Posts: 30
    • View Profile
Hi, you can enable show grid in MS(menu Model - Show/Hide Items) and then manually rotate and translate model somewhere near [0,0,0](two crossed lines in grid)...it does not need to be perfectly aligned with XY plane. Then export 3d model to blender, do cleaning and export back to MS.

Yea.. its not as easy with their translation gizmo.. I try to do this but always just never works out that well and im spending way to much time mucking around trying to get it to align.

Ideally a center point could be added to the model and that center point could be snapped to 0,0,0

but thank you for your reply.

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13990
    • View Profile
Hello gateway,

How does the default orientation of the coordinate system axes look like in Model view, relatively to the model? Can you provide such screenshot and similar with Show Cameras option enabled?

Also please specify, if you are working with such types of projects in Standard edition from the very beginning (I mean, that the projects have not been pre-processed in Professional edition)?
Best regards,
Alexey Pasumansky,
Agisoft LLC

gateway

  • Newbie
  • *
  • Posts: 30
    • View Profile
Thanks for the reply..  I created a video of m workflow and I also used advice from the post above about turning on the grid and moving the mesh around to eventually get it sorta aligned but even then it comes in at 90 degree's in blender.

So the first part of the video is the Wizard Geyser.. this was just a project I did, added photos, aligned , textured, decimated, exported and then brought into blender, as you can see its at a weird angle and I have to snap the object to the center of the origin then get it aligned so its easier to work with.

The 2nd part is of Fly Geyser which I used the above method of turning on the grid and moving the object into place, however you can see it still comes in as 90 degrees off.. which is much better to fix.

So while this works I have to remember after clean up to rotate it 90 on the translation and hope it comes in properly back into MS.

Also on a big big separate note no matter what I do with drone scanning landscapes have sooooooooo many overlapping faces.. even after decimating, smoothing in MS.. I spend hours cleaning that up.. thoughts?  sorry dont mean to distract from the main issue.

IM using the standard version since I cant afford pro :(

video to my issues.. https://youtu.be/WsUTOVmUWpo it was still processing when I posted this..

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13990
    • View Profile
Hello gateway,

According to your video, after 0:40 you need to switch on Rotate Object tool (button on the Toolbar) - it will fix the coordinate system (axes shown in the bottom-right corner), so you can modify the object's orientation relative to it. It may be also convenient, if you use predefined views (Top, Bottom, Front, Back, Left and Right) and switch the Model view to orthographic mode from perspective option.
In a similar way you can use Move Object tool to align the model's center with the grid center.

After all modifications switch back to Navigation mode and export the model.

And when importing the model to Blender you need to use Z-up convention (not Y up).
Best regards,
Alexey Pasumansky,
Agisoft LLC

gateway

  • Newbie
  • *
  • Posts: 30
    • View Profile
Thank you, Ill give it a shot and report back, but can we get just snap model to 0,0,0 then rotate as needed?

Also any idea on these massive face issues with overlapping etc? its a lot of work to clean up..

Bzuco

  • Full Member
  • ***
  • Posts: 144
    • View Profile
@gateway
I can only give you idea of my workflow, but it is outside of MS:
-create pointcloud in MS, export it to cloudcompare and apply poisson surface reconstruction, then export mesh to meshlab and apply "Simplification: Quadric edge collapse decimation" filter(this gives you overlap/dark triangles free mesh)

cbnewham

  • Full Member
  • ***
  • Posts: 118
    • View Profile
The thing that annoys me the most is that MS and Blender have their X-axis at 90 degrees to each other. I always have to do a rotation of -90 in Blender to get the model to the correct orientation.

gateway

  • Newbie
  • *
  • Posts: 30
    • View Profile
The thing that annoys me the most is that MS and Blender have their X-axis at 90 degrees to each other. I always have to do a rotation of -90 in Blender to get the model to the correct orientation.

when you import to blender select z up and it should work

gateway

  • Newbie
  • *
  • Posts: 30
    • View Profile
@gateway
I can only give you idea of my workflow, but it is outside of MS:
-create pointcloud in MS, export it to cloudcompare and apply poisson surface reconstruction, then export mesh to meshlab and apply "Simplification: Quadric edge collapse decimation" filter(this gives you overlap/dark triangles free mesh)

I totally forgot about meshlab.. thanks for the reminder.. do you run any other options in meshlab or just that one?

shameline

  • Newbie
  • *
  • Posts: 4
    • View Profile
I just had a similar issue, and not realizing Blender needs a specific import (and export setting). I found out that if I orient properly my model in MS (as mentioned earlier by Alexey), and import in Blender with the proper import setting, and DO NOT change the orientation of the model in Blender, re-export with the same z up setting, that MS will be able to replace that model with no problem.

Alexey, would you be able to tell use why Z is up? Is it a Blender thing, or the way Metashape place its model in space?

What if I work with someone who uses Z Brush, or another software, are there specific orientation settings for specific softwares, or is Blender an exception?

Bzuco

  • Full Member
  • ***
  • Posts: 144
    • View Profile
@gateway Sorry for late reply, I think only that one option in meshlab.

@shameline There are right and left handed coordinate systems and Z/Y up, see image in attachment.


Medive

  • Newbie
  • *
  • Posts: 2
    • View Profile
Not sure if that helps you, but in Blender I select the model and choose "Object" - "Origin" -"Set Origin to center of mass" and  set the location values in the transform window in the up right corner to zero. Works perfectly fine for me-
 

shameline

  • Newbie
  • *
  • Posts: 4
    • View Profile
Thanks for the attachment @Bzuco , very helpful !

Will try this @Medive, thank you!