Forum

Author Topic: [SOLVED] Autel EVO II thermal mosaic issue  (Read 1658 times)

vladal

  • Newbie
  • *
  • Posts: 3
    • View Profile
[SOLVED] Autel EVO II thermal mosaic issue
« on: July 07, 2022, 02:56:22 PM »
Hello,
I am trying to create a mosaic from a thermal dataset captured with Autel EVO II, using the .tiff files (it also has .jpg, but these only provide a heatmap as far as I understand).
Image alignment went just fine, but as I tried to create a dense cloud, I've received an error I've never seen before (attached screenshot).


I suspect that it has to do with camera calibration, but I've no idea what parameters to set and the specs on Autel's website are not helpful.

Help will be appreciated, I out of ideas.
« Last Edit: July 24, 2022, 10:40:08 AM by vladal »

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14107
    • View Profile
Re: Autel EVo II thermal mosaic issue
« Reply #1 on: July 08, 2022, 07:56:08 PM »
Hello vladal,

Can you please specify Metashape version used and also provide the part of the processing log from the Console pane related to failed operation Build depth maps or Build dense cloud.
Best regards,
Alexey Pasumansky,
Agisoft LLC

vladal

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Autel EVo II thermal mosaic issue
« Reply #2 on: July 10, 2022, 03:22:23 PM »
Hello vladal,

Can you please specify Metashape version used and also provide the part of the processing log from the Console pane related to failed operation Build depth maps or Build dense cloud.

Hi Alexey,
Metashape version is 1.71 (build 11797)

Here is the part from the log with the failure of Build dense cloud:

2022-07-10 15:22:43 BuildDenseCloud: quality = High, depth filtering = Mild, PM version, point colors = 0
2022-07-10 15:22:43 Generating depth maps...
2022-07-10 15:22:43 Preparing 748 cameras info...
2022-07-10 15:22:43 cameras data loaded in 0.147 s
2022-07-10 15:22:43 cameras graph built in 0.252 s
2022-07-10 15:22:43 filtering neighbors with too low common points, threshold=50...
2022-07-10 15:22:43 avg neighbors before filtering: 46.5455 (41% filtered out)
2022-07-10 15:22:43 limiting neighbors to 40 best...
2022-07-10 15:22:43 avg neighbors before limiting: 27.6096 (0% limited out)
2022-07-10 15:22:43 neighbors number min/1%/10%/median/90%/99%/max: 4, 11, 18, median=29, 34, 37, 37
2022-07-10 15:22:43 cameras info prepared in 0.402 s
2022-07-10 15:22:43 saved cameras info in 0.014
2022-07-10 15:22:43 Partitioning 748 cameras...
2022-07-10 15:22:43 number of mini clusters: 58
2022-07-10 15:22:43 20 groups: avg_ref=37.4 avg_neighb=95.2 total_io=355%
2022-07-10 15:22:43 max_ref=39 max_neighb=135 max_total=173
2022-07-10 15:22:43 cameras partitioned in 0.004 s
2022-07-10 15:22:43 saved depth map partition in 0.006 sec
2022-07-10 15:22:43 loaded cameras info in 0.03
2022-07-10 15:22:43 loaded depth map partition in 0 sec
2022-07-10 15:22:43 already partitioned (38<=50 ref cameras, 61<=200 neighb cameras)
2022-07-10 15:22:43 group 1/1: preparing 99 cameras images...
2022-07-10 15:22:43 point cloud loaded in 0.002 s
2022-07-10 15:22:43 Found 1 GPUs in 0 sec (CUDA: 0 sec, OpenCL: 0 sec)
2022-07-10 15:22:43 Using device: Quadro RTX 4000, 36 compute units, free memory: 6675/8192 MB, compute capability 7.5
2022-07-10 15:22:43   driver/runtime CUDA: 11020/8000
2022-07-10 15:22:43   max work group size 1024
2022-07-10 15:22:43   max work item sizes [1024, 1024, 64]
2022-07-10 15:22:44 Finished processing in 0.982 sec (exit code 0)
2022-07-10 15:22:44 Error: Assertion 239012012300097 failed at line 891!
>>>

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14107
    • View Profile
Re: Autel EVo II thermal mosaic issue
« Reply #3 on: July 12, 2022, 04:23:23 PM »
Hello vladal,

The issue which caused Assertion 239012012300097 (related to unsupported data format for GPU-based processing), seems to have been fixed in the version 1.7.4.

Can you please check, if you are no longer observing any similar problems in the latest release version: 1.8.3.
Best regards,
Alexey Pasumansky,
Agisoft LLC

vladal

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Autel EVo II thermal mosaic issue
« Reply #4 on: July 24, 2022, 10:39:48 AM »
Hello vladal,

The issue which caused Assertion 239012012300097 (related to unsupported data format for GPU-based processing), seems to have been fixed in the version 1.7.4.

Can you please check, if you are no longer observing any similar problems in the latest release version: 1.8.3.

Hello Alexey,
I can confirm that the issue does not appear on version 1.8.3, I have successfully built an orthomosaic.

Thank you for you help!