Author Topic: Metashape : Calibrate Lens Problem  (Read 5330 times)


  • Newbie
  • *
  • Posts: 6
    • View Profile
Metashape : Calibrate Lens Problem
« on: August 01, 2022, 11:13:48 AM »

First, I made a calibration rocket to get a calibration result. In the rocket, there're lots of metashape markers and checkerboards. (You can see this rocket from first image. )
Thanks to the metashape marker, I could get Intrinsic and Extrinsic camera data from 9 view images.   
But I wanted to get more accurate Intrinsic data first, so tried to do [Metashape>Tools>Lens>Calibrate Lens..]. 
But it failed to find Checker board, and I have no idea why this happen... maybe the checker board size in image problem.
I attach my input and output(result) images.  (input image's resolution is reduced to attach)

Second, i attach another result that I tried.
I made a image which has 1 checker board for 1 image, and do  [Metashape>Tools>Lens>Calibrate Lens..] again.
In this case, meta shape find checker board but failed to get calibration data. (gray dots)
This works the same if I run it with 4 images  or increase the brightness with long exposure time.

I think I missed some options for Lens Calibration, because Opencv module can get calibration from those images,

Could you let me know why this is happening?
Thank you very much.

This is URL that I referenced.
« Last Edit: January 27, 2023, 05:48:02 AM by jungeun »

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14848
    • View Profile
Re: Metashape : Calibrate Lens Problem
« Reply #1 on: August 01, 2022, 06:12:46 PM »
Hello jungeun,

Can you please share 4 image set that you are using for the lens calibration and that doesn't work on your side?

Do all of those images look more o less similar to calibration_input2.JPG?
Best regards,
Alexey Pasumansky,
Agisoft LLC


  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Metashape : Calibrate Lens Problem
« Reply #2 on: August 03, 2022, 08:51:25 AM »
Dear Alexey,

I found the reason why my second calibration test ( 4 images, each containing one checkerboard ) failed.

In that test, 4 images were just cropped from 'first big image that I attached (imgA)'
Due to my mistake in the process, the size of 4 images set was different, so program recognize them to 4 different cameras' pictures.
after matching the size, calibration works.

But this case is not proper calibration for my camera because they are cropped images from 'imgA'
So I tried copy 'imgA'  4 times, and just remove(fill the area with gray color) other checker boards except one for each copied image, to make sure one image contains one checkerboard.
But it also failed, I guess it's because the checkerboard is too small for the image.

Is there any way to use calibration with imgA? or is it the only way that making checker board take a maximum area of each photo?

Thank you very much!
« Last Edit: August 03, 2022, 09:27:12 AM by jungeun »