Forum

Author Topic: mesh generation extremely low cpu and gpu usage  (Read 235 times)

bassistas

  • Newbie
  • *
  • Posts: 13
    • View Profile
mesh generation extremely low cpu and gpu usage
« on: August 03, 2022, 05:44:24 PM »
Hi guys,
I'm trying to create a mesh from 50 laser scans and 2788 (50mpixel) photos but after the generation of the depth maps the CPU and GPU usage is dropping to almost 0-3% and only the disk usage activity hovers around 30-40mb/sec as you can see in this screenshot. If I leave it like that the estimated time starts to explode and shows 8 to 10 days or more which is extreme for such an amount of data and the hardware I use. Is this a metashape bug? I'm using the latest 1.8.4 build.

PolarNick

  • Jr. Member
  • **
  • Posts: 64
    • View Profile
Re: mesh generation extremely low cpu and gpu usage
« Reply #1 on: August 04, 2022, 11:54:55 AM »
Hi, like you said - it seems to be Input/Ouput-bound (i.e. IO is slow - see also 98% IO in logs). Can you transfer your project from external drive (WB My Book) to local internal disk for processing? (to SSD ideally)
« Last Edit: August 04, 2022, 12:06:00 PM by PolarNick »

Bzuco

  • Full Member
  • ***
  • Posts: 113
    • View Profile
Re: mesh generation extremely low cpu and gpu usage
« Reply #2 on: August 04, 2022, 05:37:34 PM »
30-40MB/s is exactly limit of USB2.0 .But if you already have that disk connected in USB 3.0, then it should not slow the process much. Also generating mesh from depthmaps is not 100% multi threaded, there are also few tasks single threaded.
Can you describe a little bit more about your project and settings you are using? ...resolution of depth maps?, it is drone top down photorammetry? from how large area are you trying generate the mesh?...