Forum

Author Topic: Weird banding/noise pattern in mesh from depth maps  (Read 1545 times)

jenkinsm

  • Jr. Member
  • **
  • Posts: 70
    • View Profile
Weird banding/noise pattern in mesh from depth maps
« on: October 28, 2022, 02:52:25 AM »
Does anyone know what is causing this weird banding pattern in my mesh? (See attached image)

I generated the mesh from depth maps using a set of 22,785 images that were well-aligned.

I'm wondering if Optimizing Cameras caused this.

It's a big problem because it shows up in my normal maps and looks terrible in-game.

Open to hearing all suggestions. Thanks!


Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14504
    • View Profile
Re: Weird banding/noise pattern in mesh from depth maps
« Reply #1 on: November 01, 2022, 01:10:28 PM »
Hello jenkinsm,

Can you please share a dataset to support@agisoft.com that can be used to reproduce the issue? We would need the set of original images, project with the camera alignment results and the PDF report exported from the fully processed project, so that we would be able to use the same processing settings on our side.
Best regards,
Alexey Pasumansky,
Agisoft LLC

jenkinsm

  • Jr. Member
  • **
  • Posts: 70
    • View Profile
Re: Weird banding/noise pattern in mesh from depth maps
« Reply #2 on: November 01, 2022, 08:51:31 PM »
The project has over 7TB of images, so I'll try to reproduce the banding in a new project later today with a small subset of images and send that over.

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14504
    • View Profile
Re: Weird banding/noise pattern in mesh from depth maps
« Reply #3 on: November 01, 2022, 11:32:20 PM »
Hello jenkinsm,

Maybe you can take a subset of images for the problematic area (like <200-300 images) and see, it the problem is still observed there?
Best regards,
Alexey Pasumansky,
Agisoft LLC

jenkinsm

  • Jr. Member
  • **
  • Posts: 70
    • View Profile
Re: Weird banding/noise pattern in mesh from depth maps
« Reply #4 on: November 03, 2022, 02:09:19 AM »
Yes, I was able to reproduce the problem with a subset of 299 images and 3 GCPs.

The banding is present both when creating a mesh from depth maps and from a dense cloud, but the banding is sharper and narrower from the dense cloud vs wide and blurry from the depth maps.

I created example chunks with various settings and will email a compressed archive shortly.

jenkinsm

  • Jr. Member
  • **
  • Posts: 70
    • View Profile
Re: Weird banding/noise pattern in mesh from depth maps
« Reply #5 on: January 20, 2023, 12:34:48 AM »
Hello jenkinsm,

Maybe you can take a subset of images for the problematic area (like <200-300 images) and see, it the problem is still observed there?

Hi Alexey,

Sorry for the long delay in following up on this. I just sent the project file and source image to the support team. Hopefully they can help fix this!