Forum

Author Topic: Decimating Mesh  (Read 10092 times)

RHenriques

  • Full Member
  • ***
  • Posts: 208
    • View Profile
Decimating Mesh
« on: June 22, 2011, 05:55:41 AM »
Something is wrong with the Decimating Mesh step while building geometry in this latest beta. I've run some chunks that took about 2 hours to complete the calculation until the "Integrating depth maps" step. After, the Decimating Mesh starts automatically and says that it has 80.29h to calculate!!!! It takes ages, even considering that the estimation varies. I had to force quit photoscan after one entire day with only 2% completed.  What can be wrong (if anything os wrong)? Is anyone else experiencing this? (MacOSX version)
Cheers

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13915
    • View Profile
Re: Decimating Mesh
« Reply #1 on: June 22, 2011, 05:33:49 PM »
Hello Renato,

The problem might be in RAM shortage, because decimation procedure requires more memory than memory reserved just for one model. If it is so your system tries to use swap and it is really slow.

You can set "Face count" parameter to "0" in "Build geometry" dialog. In this case decimation stage will be skipped and model will have all the reconstructed faces.
Best regards,
Alexey Pasumansky,
Agisoft LLC

RHenriques

  • Full Member
  • ***
  • Posts: 208
    • View Profile
Re: Decimating Mesh
« Reply #2 on: June 23, 2011, 03:19:43 AM »
Thanks Alexey. For now I'm going to avoid decimating mesh as you suggested. This problem is new for me. Never had it in pervious betas where decimating mesh was also used.
As someone suggested somewhere in the forums, please add a lasso selection tool for the selection of faces in the model.
Cheers