Forum

Author Topic: Metashape generates invalid SLPK  (Read 2198 times)

Raitis

  • Newbie
  • *
  • Posts: 3
    • View Profile
Metashape generates invalid SLPK
« on: December 29, 2022, 02:47:30 PM »
Hello,

All versions (1.7.4, 1.8.0, 2.0) of Metashape create SLPK files, with several problems:

This tool validates SLPK:
https://github.com/Esri/i3s-spec/tree/master/i3s_converter

Our workflow is simple, nothing fancy:
Generate mesh model => generate tiled model => clip by outer boundary and export.


1) If files are large, more than 4GB, it doesn't open in Arcgis PRO, file doesn't convert or validate. "Error : Loading resource /3dSceneLayer failed with error:NOT_FOUND"

2) If files are less than 3GB, they are validated, but:
a) Desktop Arcgis PRO opens them but few tiles disappear when zoomed in.
b) Arcgis Online loads them, but many tiles disappear when zoomed in.
c) Arcgis Online performance is awful, sometimes layer does not load at all.


I have 7GB example, generated with other software, which loads fast, and tiles are not disappearing, so this is definitely something with Metashape.

Tried all possible internal mesh formats, exporting with or without boundary, other CRS, changed tile size with the same result.

SLPK samples here:
https://files.fm/u/bhuazbuhr



Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14968
    • View Profile
Re: Metashape generates invalid SLPK
« Reply #1 on: January 13, 2023, 05:50:35 PM »
Hello raitis.upmalis,

Seems like you are using SLPK files exported from quite old Metashape version. The issue with large tiled model export to SLPK format has been fixed in the version 1.8.0 build 13354.
Best regards,
Alexey Pasumansky,
Agisoft LLC