Forum

Author Topic: Honey, I shrunk the kids...  (Read 3396 times)

JMR

  • Hero Member
  • *****
  • Posts: 504
    • View Profile
Honey, I shrunk the kids...
« on: September 24, 2023, 10:21:19 PM »
Hello. I have experienced one of the weirdest things ever with Metashape 2.0.3
I'm processing a large project with a some thousands of photos, and after finished alignment and some other pretty standard operations, I closed the project until next day.
When I open, I see the sparse cloud has been dramatically downscaled for no reason...

Any thoughts?.

José Martínez

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14890
    • View Profile
Re: Honey, I shrunk the kids...
« Reply #1 on: September 25, 2023, 08:14:59 PM »
Hello José,

What is the build number used for the image matching? Was it a new project processed from the beginning or some old re-opened project?
Best regards,
Alexey Pasumansky,
Agisoft LLC

JMR

  • Hero Member
  • *****
  • Posts: 504
    • View Profile
Re: Honey, I shrunk the kids...
« Reply #2 on: September 27, 2023, 12:27:11 AM »
Good point. I think you could have nailed it. The customer gave me a pre-processed project and he might have created using an older version, now he is working with 2.0.3. followinf my advise. This is what he did after the upgrade. He replaced images (out of camera jpg's) with a new set of jpg's from raw. So in the new project in 2.0.3 he changed pàths for all photos and realigned using the option reset current alignment, but kept marker projections placed on original jpgs.

And then we had the abnormal scale issue.

I have suggested him to start a new project from scratch but he is reluctant to align 30k photos again, mainly because the photos had been carefully organised into camera groups according to several criteria and he spent quite a long time creating this structure....
What would be a smart way to copy the project structure to a new project file?

Regards

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14890
    • View Profile
Re: Honey, I shrunk the kids...
« Reply #3 on: September 27, 2023, 03:07:21 PM »
Hello José,

Maybe the easiest solution for the current issue would be deleting the tie points in the Model view (select all tie points, then delete) and executing the following line in the Console pane:
Code: [Select]
Metashape.app.document.chunk.triangulateTiePoints()
If it still doesn't help, may be reasonable to run Tools Menu -> Tie points -> Build Tie Points procedure - in this case the exterior and interior orientation parameters would be preserved, but the images will be re-matched. This will be, of course, much longer that the previous approach.

Also worth checking that the coordinate information input for cameras and markers is correct and corresponds to the coordinate system selection in the Reference pane settings dialog.
Best regards,
Alexey Pasumansky,
Agisoft LLC