Forum

Author Topic: Seems like 2.0 is using more RAM to generate textures  (Read 2695 times)

jenkinsm

  • Jr. Member
  • **
  • Posts: 72
    • View Profile
Seems like 2.0 is using more RAM to generate textures
« on: March 10, 2023, 12:21:50 AM »
I haven't done a direct back-to-back comparison, but I was able to generate 8K, 16K, and 32K textures before upgrading to 2.0 and now it seems like I'm limited to 4k textures. The projects I'm testing now are much smaller with much fewer pictures, but the scene is very different so that might be a factor here.

Has Metashape been altered to use more RAM when generating textures? I'll try to do an A/B test between 1.8 and 2.0 to provide more concrete data. Right now I'm pretty frustrated, so I hope this is a bug and not a new limitation.

tazzo

  • Full Member
  • ***
  • Posts: 157
    • View Profile
Re: Seems like 2.0 is using more RAM to generate textures
« Reply #1 on: March 10, 2023, 12:34:06 AM »
Hello, can you generate multiple 4k textures (ex. 4 or more)?

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14890
    • View Profile
Re: Seems like 2.0 is using more RAM to generate textures
« Reply #2 on: March 15, 2023, 07:09:41 PM »
Hello jenkinsm,

Can you share any texture generation log from 2.0 version? So that we can see the parameters used for the task, number of polygons in the model and etc.
Please also specify the resolution of images used and data type (number of channels and bit depth).

Additionally please specify, if you are speaking about RAM or VRAM usage and how it is monitored (via any external tool or by a number in Metashape project info)?
Best regards,
Alexey Pasumansky,
Agisoft LLC