Forum

Author Topic: Build mesh face count stimations totally off  (Read 2685 times)

Paulov

  • Newbie
  • *
  • Posts: 44
    • View Profile
Build mesh face count stimations totally off
« on: May 09, 2023, 10:42:31 AM »
Hi,

When meshing a point cloud, the preset low, med, high, by the name have a face count stimate when building a mesh out of a point cloud (.las import).

This stimation is completelly off.

Lets say in low stimates are 2.5M, the outcome is 28M. And so on.

Also I've noticed this has worsen from 2.0 beta. Where medium would output a 10,5M and medium now outputs 56M mesh.

Also noticed that for same face count, input manually via "custom"  face count, the latest version seems a bit noisier than in beta, yet I've to say it captures better hard edges.

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14927
    • View Profile
Re: Build mesh face count stimations totally off
« Reply #1 on: May 10, 2023, 07:20:23 PM »
Hello Paulov,

Do you observe it only for imported point clouds or for the point clouds generated in Metashape directly and used as a source for the mesh reconstruction?

Can you please specify a few examples of point number in the source point clouds, target face count according to High/Medium or Low preset and the actual resulting polygon count number?
Best regards,
Alexey Pasumansky,
Agisoft LLC

Paulov

  • Newbie
  • *
  • Posts: 44
    • View Profile
Re: Build mesh face count stimations totally off
« Reply #2 on: May 11, 2023, 10:19:17 PM »
Hello,

It happens only to the generated mesh. The number of points is the same as the source file, see attached image.

I can upload a .las file for you to test. I tested with aerial and ground scanner just in case it was something specific of a dataset.