Forum

Author Topic: v2.0.2 Tweaks BuildDenseCloud/max_neighbors / pm_max_neighbors NOT FOUND  (Read 2922 times)

sonno

  • Newbie
  • *
  • Posts: 19
    • View Profile
Hi,

I use version 2.0.2 to fix the ASSERT problem of the neighbors.

By default the calculation of the dense point cloud uses 100 neighbors at most. When I try to increase this value by preference -> advanced -> tweaks, the values BuildDenseCloud/max_neighbors / BuildDepthMaps/pm_max_neighbors parameters IS NOT FOUND.

What are the new parameter names please ? Do you have list ?

bests regards,

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14965
    • View Profile
Hello sonno,

Please try BuildPointCloud/max_neighbors, but specify, what issues you are facing without that.
Best regards,
Alexey Pasumansky,
Agisoft LLC

sonno

  • Newbie
  • *
  • Posts: 19
    • View Profile
Thank you Alexey. This parameter is well found by version 2.0.2. I use value = -1

In fact as explained on another post on the forum, I try to make a model of an object photographed in the dark with only 1 light source and in motion, so with a lot of shadows that change. There are many 9000 images.

During my first test without masks, I have a lot of noise and errors. I masked the shadows in the 9000 images and I get a much better dense point cloud because the parts in the shadows are not used anymore.

Now I try to improve again by increasing the number of used neighbors, to test with more. I have many images around but also at different distances. What do you think is the best way to handle this case ?

sonno

  • Newbie
  • *
  • Posts: 19
    • View Profile
Another thing, can you explain us the Max neighbors = 16 in Depth Maps info ?