Forum

Author Topic: 2.0.2 Standard: Displacement maps not exporting  (Read 4239 times)

taran

  • Newbie
  • *
  • Posts: 21
    • View Profile
2.0.2 Standard: Displacement maps not exporting
« on: July 12, 2023, 01:08:25 PM »
After generating a displacement map, when I export a model as OBJ, all maps *except* displacement are exported. I can verify the displacement map in the viewport as well as unwrapped in the mesh UV inspector.

However, exporting the displacement map via the UV inspector just exports the diffuse map.

Exporting via Export > Export Textures and selecting Displacement results in a black square if JPEG is selected and the default "Preserve Alpha" is ticked. Changing the export format to PNG exports the UV islands but they are completely black.

This happens to any model I have made in 2.0.2 or earlier.

Does this happen to anyone else in 2.0.2 Standard (build 16404) the latest release in July 2023?


e.spiridonova

  • Agisoft Technical Support
  • Newbie
  • *****
  • Posts: 38
    • View Profile
Re: 2.0.2 Standard: Displacement maps not exporting
« Reply #1 on: July 27, 2023, 12:39:06 PM »
Dear taran,

You can check the displacement map in the UV Mapping dialog window (select Tools > Mesh > View Mesh UV ), the texture is actually not completely black.

Displacement map records offsets in the scale of the model coordinates, if the model coordinates are small, then some programs can display Displacement map almost black (or almost white if the coordinates are large). This is done so that users have the opportunity to use real offsets, and not selected "by eye".

We can offer you to export the texture in *.tiff format (since *.jpg doesn't support 32-bit floating point) and use this texture file if necessary in a third-party texture editing program.
Best regards,
Elizaveta Spiridonova,
Agisoft LLC