Forum

Author Topic: Very long processing time and high system load on Matching points step  (Read 606 times)

gorkovchuk

  • Newbie
  • *
  • Posts: 2
    • View Profile
I am working with an old dataset from film cameras with fiducial marks. It has 640 black-and-white images with ~130 MPx resolution.

My PC configuration is:
i5 13600K
128GB RAM
RTX4070Ti.

I started the project in version 2.0.1. It took approximately 3 hours for alignment (depending on quality): 2 hours for key point extraction, 1 hour for matching and few minutes for estimating camera locations.
When I have upgraded to version 2.1.0 alignment step now takes days for the same dataset. I still have 2 hours for feature point extraction, and then days for Matching points. And now the Matching points step use all availlable RAM (128GB) and 100% GPU load.

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14890
    • View Profile
Re: Very long processing time and high system load on Matching points step
« Reply #1 on: February 07, 2024, 03:43:19 PM »
Hello gorkovchuk,

I suggest to check that GPU is enabled in the Preferences of Metashape window and that you see the GPU usage lines in the processing log.

Also please make sure that you are using save processing parameters as in the previous version - same key/tie point limits, same preselection. Note that with Guided Matching enabled the Key Point Limit parameter is replaced by Key Point per MPix value (in the latter case the default values are in 1000 - 2000 range).
Best regards,
Alexey Pasumansky,
Agisoft LLC

gorkovchuk

  • Newbie
  • *
  • Posts: 2
    • View Profile
GPU is enabled, I can see it in processing log.

I have reinstalled previous version 2.0.4 and made the alignment with 16000/64000 key/tie point limit per Mpix. It took 3 hours: 1.5 hours for extracting points and 1.5 hours for matching.
Then installed version 2.1.0, used exactly same parameters. It took 1.5 hours for extracting points. After 8 hours of matching it still processing and remaining time is estimated at 8 hours. I am afraid, that process will never end.

UPD: now 21 hours of processing. Obviously a bug.
« Last Edit: March 01, 2024, 02:43:18 PM by gorkovchuk »

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14890
    • View Profile
Hello gorkovchuk,

It would be helpful, if you could share the complete processing log from the beginning of the task from the version 2.1, that contains the task starting parameters. Also PDF report from the same project processed in 2.0.4 version.

And please provide the screenshot of Align Photos dialog with the settings used from the both versions, as there might be some confusion in this phrase: "16000/64000 key/tie point limit per Mpix".
Best regards,
Alexey Pasumansky,
Agisoft LLC