Forum

Author Topic: MS 2.1.0.17532 - batch import QGIS gpkg in EPSG:6318 doesn't set OuterBoundary  (Read 531 times)

andyroo

  • Sr. Member
  • ****
  • Posts: 440
    • View Profile
When I draw a polygon in QGIS, and export as a geopackage (or shapefile) in EPSG:6318, then try to import into Metashape while setting outerBoundary as the boundary type it imports successfully but does not set the outer boundary.

I can set the outer boundary after import manually or with a python script.

I'm pretty sure I tried it as a shapefile too and tried a manual import. In all cases I had to set the boundary after import.

sample gpkg and jpg attached.

jpg shows logfile with "boundary_type = OuterBoundary" and context menu with /Set Boundary Type/None checked (project state immediately after import)

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14890
    • View Profile
Hello andyroo,

Thank you for reporting the issue.

It seems that boundary setting is not applied on import for Multipolygons (and is applied to polygons properly). I think we should be able to fix it in the next version update.
Best regards,
Alexey Pasumansky,
Agisoft LLC