Forum

Author Topic: Issue with Qt library  (Read 302 times)

Benny

  • Newbie
  • *
  • Posts: 13
    • View Profile
Issue with Qt library
« on: March 01, 2024, 06:55:58 PM »
Hi,

I cannot launch Metashape anymore on my Ubuntu 22.04 LTS desktop. When I try to launch metashe.sh, I have the following error message:

Cannot mix incompatible Qt library (5.15.8) with this library (5.15.2)
Aborted (core dumped)

I updated Metashape, but that does not change anything. I also uninstalled everything related to Qt5 and reinstalled it. Nothing changes. I tried to install qtcreator to see I it could help me, but I have the same error message when I try to launch it.

I google the error message I tried many solutions, but nothing works.

Is there anyone who faced the same issue and could help me?

Thank you in advance!

Best regards,

Benoît

Benny

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: Issue with Qt library
« Reply #1 on: March 01, 2024, 07:39:53 PM »
Problem solved ... for the moment!

I followed a suggestion in this old post related to Linux: https://www.agisoft.com/forum/index.php?action=profile;area=showposts;sa=topics;u=61115

I added the following line in metashape.sh: `unset QT_PLUGIN_PATH`

It solves the issue for running metashape, but it is not a long-term fix. Anyway, if a linux user can suggest solutions, I am still interested.

Thank you in advance!

All the best,

Benoît