Forum

Author Topic: [Solved] Bug when creating dense point cloud from large mesh  (Read 630 times)

3create

  • Newbie
  • *
  • Posts: 33
    • View Profile
    • 3create
The attached screenshot should acually be a hemisphere.

I've noticed this bug on medium to large scale scenes (i.e. 100+ m).
If I crop to a small region, the dense point cloud is fine, however, when the region is larger, these strange cropping and distortion errors occur.
To reproduce:
Select a large mesh within a current Agisoft project or import a large mesh into a scene -> Build point cloud from mesh.
Metashape Pro 2.1.1
« Last Edit: June 30, 2024, 04:19:33 PM by 3create »

marcel.d

  • Newbie
  • *
  • Posts: 22
    • View Profile
Re: Bug when creating dense point cloud from large mesh
« Reply #1 on: May 26, 2024, 04:51:55 PM »
Hey, it almost looks like the bounding box is too small to contain the dense cloud.
Maybe it will work as expected if you enlarge the bounding box before generating the dense cloud?

Cheers
Marcel

3create

  • Newbie
  • *
  • Posts: 33
    • View Profile
    • 3create
Re: Bug when creating dense point cloud from large mesh
« Reply #2 on: May 26, 2024, 05:14:31 PM »
Thanks, but that "reddish" bounding box has nothing to do with the region I define in Metashape.
It's probably more of an indication that something is wrong with Metashape's internal point cloud transformation.
Btw., this bug is really easy to reproduce, just import a large mesh (500m?), i.e. as obj.
As mentioned, I'm using MS 2.1.1

vineg

  • Newbie
  • *
  • Posts: 17
    • View Profile
Re: Bug when creating dense point cloud from large mesh
« Reply #3 on: June 03, 2024, 01:19:49 PM »
Hi!

Thanks for reporting!
2.0.x should work fine.
And upcoming 2.1.2 should fix this as well.

3create

  • Newbie
  • *
  • Posts: 33
    • View Profile
    • 3create
Re: Bug when creating dense point cloud from large mesh
« Reply #4 on: June 30, 2024, 04:18:47 PM »
Thanks for the fix, can verify that this is now solved in 2.1.2  :)