Forum

Author Topic: Various GPU problems  (Read 7818 times)

cseu

  • Newbie
  • *
  • Posts: 2
    • View Profile
Various GPU problems
« on: June 28, 2011, 05:12:42 PM »
Hi, i've been evaluating PhotoScan demo version on a couple of machines and i've encountered the following issues on 2 different machines :

1. On a Core i7 iMac i disabled 2 threads (i have 6/8 activated) and checked the GPU in preferences, everything seems to be fine since the output shows the GPU info correctly :

Code: [Select]
OpenGL Vendor: ATI Technologies Inc.
OpenGL Renderer: ATI Radeon HD 4850 OpenGL Engine
OpenGL Version: 2.1 ATI-1.6.16
ARB_vertex_buffer_object: supported
ARB_framebuffer_object: supported
ARB_texture_non_power_of_two: supported
EXT_framebuffer_object: supported
Maximum Texture Size: 8192

But then i get the following error :
Code: [Select]
Reconstructing depth...
Using device: Radeon HD 4850, 10 compute units, max work group size 1024
estimating 1008x2081x224 disparity using 252x261x224 tiles, offset 0
estimating 1008x2081x224 disparity using 252x261x224 tiles, offset 0
census.cpp line 77: clEnqueueNDRangeKernel(queue, ckCensus, 2, NULL, globalWorkSize, localWorkSize, 0, NULL, NULL) failed, error -54
estimating 1008x2081x224 disparity using 252x261x224 tiles, offset 0

Which results in :
Code: [Select]
Device 1 performance: 0 million samples/sec
Device 2 performance: 76.2683 million samples/sec

Of course when i disable GPU and activate all 8 threads i have no error and the following performance :
Code: [Select]
Performance: 84.8533 million samples/sec
2. On a PC (Win7 64bits using 64bits windows version of Photoscan) the output starts with correct GPU info :

Code: [Select]
OpenGL Vendor: ATI Technologies Inc.
OpenGL Renderer: ASUS EAH5770 Series
OpenGL Version: 4.0.10243 Compatibility Profile Context
ARB_vertex_buffer_object: supported
ARB_framebuffer_object: supported
ARB_texture_non_power_of_two: supported
EXT_framebuffer_object: supported
Maximum Texture Size: 16384

But when i go to preferences in order to enable GPU, the list is empty ! I've checked and i have the latest versions of video card drivers.

Any idea ? Thanks.

Jan Wesbuer

  • Newbie
  • *
  • Posts: 39
    • View Profile
Re: Various GPU problems
« Reply #1 on: June 28, 2011, 07:24:26 PM »
Hi cseu,

Regarding OS X:
I have problems too with my ATI 5770 & OS X, lets hope that these can be fixed in the future.
(i disable Open CL in OS X)

Regarding the OPEN CL support in Windows:
Are you sure you installed the driver package with Open CL support ?

There are diverpackages out there without Open CL support and you have to install one which has it:
http://sites.amd.com/us/game/downloads/Pages/radeon_win7-64.aspx#1

It is available as individual download too:
http://sites.amd.com/us/game/downloads/Pages/radeon_win7-64.aspx#2

Best Regards
Jan
« Last Edit: June 28, 2011, 07:26:59 PM by Jan Wesbuer »
i use PS Pro, C4D and ZBrush on OS X

cseu

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Various GPU problems
« Reply #2 on: June 29, 2011, 12:37:15 AM »
Hi Jan,

Excellent, thanks a lot... the PC part is now solved i thought ASUS drivers had all what it takes, turns out they are crap. I've installed the whole ATI package you recommended, now OpenCL works !
The device performance using 2 cores of the PC Core2duo (3.2Ghz) without GPU was 35 Mspl/s, the results now are 23 for 1 core plus 42 for GPU, not bad.

About the OS X part... anyone knows if somebody is working on a fix ? Thanks.

Jan Wesbuer

  • Newbie
  • *
  • Posts: 39
    • View Profile
Re: Various GPU problems
« Reply #3 on: June 30, 2011, 12:03:16 AM »
OS X Lion is on its way... that could help. (the problem could be in the Open CL drivers too)
Or make things even worse   :-\

i use PS Pro, C4D and ZBrush on OS X

Oli63

  • Jr. Member
  • **
  • Posts: 70
  • www.geospy.at
    • View Profile
    • GeoSpy Aerial Imaging & Mapping GmbH
Re: Various GPU problems
« Reply #4 on: December 28, 2011, 04:55:38 PM »
Hi!

I am working on a iMac Core i7, with the ATI Radeon HD4850 graphics card on OS X Lion. It should use Open CL/GL as shown below. Although I checked the card in "Preferences / Open CL" it isn't used by Photoscan (see last line!).
The documentation says that support for Radeon cards begins with the series 5xxx, which is pretty disappointing, as the graphics card cannot be changed in iMacs. What is the reason, that Radeon series 4xxx are not supported though Open CL/GL works well on them and can we hope for a change? Could a new driver solve the problem?

Greetings
Oliver

--------------
OpenGL Vendor: ATI Technologies Inc.
OpenGL Renderer: ATI Radeon HD 4850 OpenGL Engine
OpenGL Version: 2.1 ATI-7.12.9
Maximum Texture Size: 8192
ARB_vertex_buffer_object: supported
ARB_texture_non_power_of_two: supported
loaded project in 2.82574 sec
initializing...
selected 33 cameras from 33 in 0.167065 sec
Loading photos...
Reconstructing depth...
Using device: Radeon HD 4850, 10 compute units, 512 MB global memory
  max work group size 1024
  max work item sizes [1024, 1024, 1024]
  max mem alloc size 128 MB
  max workgroup size c1: 64 c3: 64 zero: 256 hamming: 64 filter: 256 box: 256
  max workgroup size zero: 256 costs: 256 b1: 64 bn: 64 wta: 256 transpose: 64
estimating 848x686x32 disparity using 283x229x32 tiles, offset 0
estimating 848x686x32 disparity using 283x229x32 tiles, offset 0
GPU processing failed, switching to CPU mode
GeoSpy Aerial Imaging & Mapping GmbH
www.geospy.at