Forum

Author Topic: OpenCL Crash in Linux  (Read 3589 times)

chrismaclean

  • Newbie
  • *
  • Posts: 4
    • View Profile
OpenCL Crash in Linux
« on: March 12, 2014, 10:28:30 PM »
Getting a hard crash and reboot when generating the dense cloud with OpenCL turned on.

Pertinent Info:

-Happens with versions 1.0.0, 1.0.1, 1.0.2 and 1.0.3
-Running 2 Titans reducing cores from 32 to 30 in Photoscan.
-Running 331.49 Nvidia Driver
-OS: Opensuse 12.3

*Doesn't crash when OpenCL is turned off.

Help with this would be great.  Thanks!

Wishgranter

  • Hero Member
  • *****
  • Posts: 1202
    • View Profile
    • Museum of Historic Buildings
Re: OpenCL Crash in Linux
« Reply #1 on: March 13, 2014, 01:00:58 AM »
try run it with just ONE Titan card, if it works, if yes, tehn ad 2nd and report. See temperatures of cards should be at leas one slot free between them - temperature problems.  Disable 4cores totaly so 28 cores and then disable ALL cores on CPU..... report back
----------------
www.mhb.sk

chrismaclean

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: OpenCL Crash in Linux
« Reply #2 on: March 14, 2014, 07:46:38 PM »
Thanks. One card works, adding the second causes the crash.

-Cards are two slots apart.
-Tried with both 31/32 cores and 30/32 cores with one card: both work.




Wishgranter

  • Hero Member
  • *****
  • Posts: 1202
    • View Profile
    • Museum of Historic Buildings
Re: OpenCL Crash in Linux
« Reply #3 on: March 19, 2014, 03:57:33 PM »
Tr replace - use one card by other and find out if its not a faulty card, DISABLE all cores on CPUs in OpenCL settings and run again. let me know

----------------
www.mhb.sk