Forum

Author Topic: Best settings to remove this type of artifaction  (Read 6406 times)

Echostorm

  • Newbie
  • *
  • Posts: 24
    • View Profile
Best settings to remove this type of artifaction
« on: April 14, 2014, 06:56:42 AM »
Just having some issues regarding Warping and Artifacting when Exporting models as Orthophotos(see attached photo).
We have a 60% overlap on all the photos that are being ran through the Following Batch Process:

Align Photos
- Accuracy: High
- Pair preselection: Ground control
- Point Limit: 40000
- Constrain Features by mask: Yes
Optimise Alignment
Left on default settings
Build Dense Cloud
- Quality: High
- Depth Filtering: mild
- Reuse depth maps: No
Build Mesh
- Surface Type: Height Field
- Source Data: Sparse Cloud
- Interpolation: Enabled(default)
- Face Count Medium
- Custom Face count 200,000

15 GCP's are then added to the file and then put through another batch process with the following parameters:
Optimize Alignment
-Default settings
Build Dense Cloud
- Quality: mild
- Depth Filtering: mild
- Reuse depth maps: no
Build mesh
- Surface type: Height field
- Source data: Dense cloud
- Interpolation: Enabled
- Face count: medium
- Custom Face count: 4,000,000
 
Once it was exported as a Geotiff it left us with the results in the Top half of the attached photo.
The Bottom Half was rendered with much lower settings and resulted in a significant decrease in the amount of artifacting taking place on the final image.
The Setting for the Process on the bottom half were:
Align Photos
- Accuracy: Low
- Pair Preselection: Ground Control
- Point Limit: 10,000
- Constrain Features by mask: Yes
Optimize Alignment
- Default
Build Mesh
- Surface Type: Height Field
- Source Data: Sparse Cloud
- Interpolation: Enabled(default)
- Face Count Medium
- Custom Face count 200,000

These Parameters resulted with very limited artifacting, but the warping in the photo increased significantly.
We were wondering if anyone had some advise on how we could decrease both artifacting and warping in our orthophoto's

Thanks



stihl

  • Sr. Member
  • ****
  • Posts: 408
    • View Profile
Re: Best settings to remove this type of artifaction
« Reply #1 on: April 14, 2014, 12:49:22 PM »
I'm curious to your workflow as you first align the photos, then optimize (without GCP?) then you build a dense cloud and then you build a mesh from the sparse cloud and not the dense cloud... doesn't make much sense to me. Ontop of that you then delete your previous work by then adding GCP's and optimizing it again.

I've had artifacts issues in True ortho's as well. My conclusion is that it comes down to not enough overlap or blurry photos so it can't find the proper textures to match points on in the alignment process.

What I recommend is following this exact workflow:

Align Photos
- Accuracy: High
- Pair preselection: Ground control
- Point Limit: 500000 (500k!)
- Constrain Features by mask: No

-Add all GCP's

-Uncheck all camera positions and just leave GCP active

Optimise Alignment
-Left at default

Build Dense Cloud
- Quality:  High (Ultrahigh if your computer can handle it)
- Depth Filtering: mild
- Reuse depth maps: No

Build Mesh
- Surface Type: Height Field
- Source Data: Dense cloud
- Interpolation: Enabled(default)
- Face Count High

In my experience, having a large sparse cloud with as many points as possible and then creating an Ultra mild dense cloud from that yields the best results.

After viewing your attachment, my conclusion is that the bottom half picture isn't a True Orthophoto at all as you can see the sides of the buildings. That also explains why you're not seeing as many artifacts (or none at all) it's because PhotoScan simply cuts out the best looking photo for that area, but it's not from a nadir viewpoint. The upper half is a True Orthphoto, just with artifacts due to a not enough dense pointcloud.
Though I could be wrong of course. Perhaps someone from PhotoScan can give feedback on this.

« Last Edit: April 14, 2014, 12:56:24 PM by stihl »

Echostorm

  • Newbie
  • *
  • Posts: 24
    • View Profile
Re: Best settings to remove this type of artifaction
« Reply #2 on: April 22, 2014, 05:02:23 AM »
Thanks stihl,

I agree regarding your last comment. I have been running some tests and will get back to you. Although, I can definately not do things anywhere near ultra, as I have 35,000 22megapixel images covering 200 sq km. It would take our computer 50 years to complete!