Forum

Author Topic: Import masks for Active Chunk result in jagged edges, bad masks  (Read 4248 times)

Owen

  • Newbie
  • *
  • Posts: 4
    • View Profile
I've been running into some inconsistent and expensive problems when importing background masks for an Active Chunk consisting of some 70 cameras.

When masks are imported for the whole chunk, the mask edges, on many but not all pictures, are jagged and useless, eating into important pixels of the subject.

Selecting the problem photos one by one and reimporting the masks for the selected photo cleans the jagged edges. All I do is reimport the mask onto the matching photo, the tolerance is left the same.

I've attached a before and after picture. If you guys have any ideas or suggestions please vocalize! All I can think is photoscan needs a more robust masking system.
« Last Edit: April 24, 2014, 11:16:50 AM by owen »

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14003
    • View Profile
Re: Import masks for Active Chunk result in jagged edges, bad masks
« Reply #1 on: April 24, 2014, 03:24:41 PM »
Hello owen,

Could you please sent a couple of photos with the background images that can be used to reproduce the problem on our side?
Best regards,
Alexey Pasumansky,
Agisoft LLC

Owen

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Import masks for Active Chunk result in jagged edges, bad masks
« Reply #2 on: April 26, 2014, 02:02:30 AM »
Alexey, thank you for your response!

After some further testing it appears the 'Active Chunk' masking becomes less accurate with higher numbers of photos in the project.

I tested a project with only 4 photos and all the batch imported masks were clean. With 10 photos, two photos began to show signs of bad edges, and with 30 photos, even more batch imported masks were showing bad edges.

I will send you an email with a link to download a sample project I shot and ran through PhotoScan this morning. I will include all photos and their correctly named background masks, as well as some screen shots of bad edges I got when I ran the project, and the clean edges achieved when reimported for 'Current Photo'.

Let me know if you need anything else! :)

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14003
    • View Profile
Re: Import masks for Active Chunk result in jagged edges, bad masks
« Reply #3 on: April 27, 2014, 02:32:22 PM »
Hello Owen,

And what tolerance value have you been using? We are currently trying to reproduce the issue, but still got same masks genrated for Active Chunk and Current Photo (with the same tolerance values). We'll also check it on Mac OS, just for case it is OS related problem.
Best regards,
Alexey Pasumansky,
Agisoft LLC

Owen

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Import masks for Active Chunk result in jagged edges, bad masks
« Reply #4 on: April 28, 2014, 06:30:08 AM »
Hi Alexey,

I've been experimenting with different tolerances, but for this test a tolerance of 8 was used for all masks.

Because the background of the capture stage is white, lighter clothing is sometimes masked out by mistake, requiring a lower tolerance to be set. I use the square select tool and Shift_command_S to do some cleaning on masks, but the other selection tools, such as the intelligent scissors, are too slow/unresponsive to function properly. But that seems to be another issue.

Yes Mac OSX 10.9.2 is being used, I look forward to your findings! :)
« Last Edit: April 28, 2014, 06:35:20 AM by Owen »