Forum

Author Topic: Why textures exported in PNG are different from JPG format?  (Read 3734 times)

sastun1962

  • Newbie
  • *
  • Posts: 36
    • View Profile
Why textures exported in PNG are different from JPG format?
« on: August 27, 2014, 10:41:26 AM »
Hi to all,
I have exported an OBJ with PNG textures and the model (an archaeological structure) have the surface textures "cracked" with thin grey lines...
After a control I have exported the same textures in JPG format and all is good in the final model...
If I compare the same textures, in the PNG format are pieces in a white background, and the JPG textures are connected with a colored shade background.
Why this difference?

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13913
    • View Profile
Re: Why textures exported in PNG are different from JPG format?
« Reply #1 on: August 27, 2014, 10:44:34 AM »
Hello sastun1962,

Texture saved in PNG and TIFF format contain alpha-channel that actually covers the interpolated colors in between the texture atlas charts.

You can remove alpha-channel in Xnview, for example, or adjust 3D viewer settings to not use alpha.

The same case has been already discussed here on forum: http://www.agisoft.ru/forum/index.php?topic=1927
Best regards,
Alexey Pasumansky,
Agisoft LLC

sastun1962

  • Newbie
  • *
  • Posts: 36
    • View Profile
Re: Why textures exported in PNG are different from JPG format?
« Reply #2 on: August 27, 2014, 12:17:08 PM »
Many thanks Alexey!
 :)