Forum

Author Topic: Creating texture freezes  (Read 6872 times)

Patribus

  • Full Member
  • ***
  • Posts: 170
    • View Profile
Creating texture freezes
« on: September 27, 2014, 12:50:00 PM »
Hello,

I'm having the following problem

I'm working on projects with around 1500 photos and a mesh with > 3.000.000 faces.

When I try to create a texture the process freezes at 70%.  I had this now for more than one project with similar parameters...

Why is this? Is it possible the the numbers are just too high?

Best regards

PS: forgot to say that this behavior is independent of the size and count of texture
« Last Edit: September 27, 2014, 01:23:29 PM by Patribus »

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14927
    • View Profile
Re: Creating texture freezes
« Reply #1 on: September 27, 2014, 01:30:00 PM »
Hello Patribus,

What was the mesh reconstruction parameters (interpolation especially) and is color correction option on?
Best regards,
Alexey Pasumansky,
Agisoft LLC

Patribus

  • Full Member
  • ***
  • Posts: 170
    • View Profile
Re: Creating texture freezes
« Reply #2 on: September 27, 2014, 04:33:30 PM »
no interpolation, no color correction

(uau, an answer on a saturday, respect ;-))

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14927
    • View Profile
Re: Creating texture freezes
« Reply #3 on: September 28, 2014, 12:44:16 AM »
Hello Patribus,

With the interpolation disabled your model may consist of huge number of isolated polygons, causing slow texturing process. I suggest to use the Enabled interpolation method and check the texturing time for this case.
Best regards,
Alexey Pasumansky,
Agisoft LLC

Patribus

  • Full Member
  • ***
  • Posts: 170
    • View Profile
Re: Creating texture freezes
« Reply #4 on: September 28, 2014, 02:17:38 AM »
hi,

well, I can test it with interpolation, but just to test time, since the interpolation doesn't make sense due to the complexity of the model.

would the be a way to avoid the 'freezing' or the infinite calculation times.

if I disable half of the 1500 images, would that make sense from the calculation point of view?

cheers

Patribus

  • Full Member
  • ***
  • Posts: 170
    • View Profile
Re: Creating texture freezes
« Reply #5 on: September 28, 2014, 02:32:52 PM »
Another point: the problem that the process freezes at 70% is that I'm not able to cancel it. I have to kill the process through task manager.....

Patribus

  • Full Member
  • ***
  • Posts: 170
    • View Profile
Re: Creating texture freezes
« Reply #6 on: September 29, 2014, 05:26:18 PM »
Alexey, I have another question concerning the freeze at 70%.

I have a 'complex' model. In one version I create the mesh with interpolation, in the other without. The first one has aroun 1.2 million faces, the latter one only 1.0 million faces.  Creating the  texture for the interpolated mesh is no problem, for the mesh created without interpolation I always get the freeze at 70%.

So, in fact the interpolated has more polygones than the other one. Is the reason for the problem in the latter one the fact, that the faces are isolated?

Cheers


Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14927
    • View Profile
Re: Creating texture freezes
« Reply #7 on: September 29, 2014, 05:33:56 PM »
Hello Patribus,

Yes, multiple isolated polygons results in scattered texture atlas (in the Console pane you should see the number of texture atlas charts) with a lot of tiny charts. And even if the process will be finished that result may be unsatisfactory due to extremely pixelated texture.
Best regards,
Alexey Pasumansky,
Agisoft LLC