Forum

Author Topic: GTX 760 GPU failed, switching to CPU mode  (Read 7584 times)

edcarlosSantana

  • Newbie
  • *
  • Posts: 1
    • View Profile
GTX 760 GPU failed, switching to CPU mode
« on: September 18, 2014, 05:29:23 PM »
Hello Guys,

I alredy viewed some post about it, but mostly about AMD cards and NVidia GTX 66ti or lower,

When I build the dense cloud, i recive the always the same message "GPU failed, switching to CPU mode" .  Using thee APP GPU CAPS , show me that my card doesnt support Open CL.

My configuration:
i7 4790
16Gb memory
120Gb SSD
2x GTX 760 Zotac both with 2 gb of memory


Somebody can help me?

Cheers.

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14937
    • View Profile
Re: GTX 760 GPU failed, switching to CPU mode
« Reply #1 on: September 18, 2014, 05:36:48 PM »
Hello edcarlosSantana,

This issue is related to the nVidia drivers version 340.52, please roll-back to any previous driver version.

Next PhotoScan version should work fine with these drivers.
Best regards,
Alexey Pasumansky,
Agisoft LLC

Sebas80

  • Newbie
  • *
  • Posts: 31
    • View Profile
Re: GTX 760 GPU failed, switching to CPU mode
« Reply #2 on: October 10, 2014, 05:32:33 PM »
The same issue for me with a NVidia Quadro K5000. I've installed previous drive version and now works great.

pjenness

  • Newbie
  • *
  • Posts: 45
    • View Profile
    • IMDB
GPU processing failed, switching to CPU mode
« Reply #3 on: November 16, 2014, 05:05:54 AM »
Hiya
I have a brand new Machine and install.

THe dense cloud process is failing on GPU

Code: [Select]
Using device: GeForce GTX 970, 13 compute units, 4096 MB global memory
  max work group size 1024
  max work item sizes [1024, 1024, 64]
  max mem alloc size 1024 MB
Using device: GeForce GTX 980, 16 compute units, 4096 MB global memory
  max work group size 1024
  max work item sizes [1024, 1024, 64]
  max mem alloc size 1024 MB
initializing...
selected 32 cameras from 32 in 0.129 sec
Loading photos...
Reconstructing depth...
[GPU] estimating 2976x4740x1728 disparity using 992x948x8u tiles, offset -454
[GPU] estimating 3233x4767x544 disparity using 1078x954x8u tiles, offset -145
ocl_engine.cpp line 320: clWaitForEvents failed, error -9999
GPU processing failed, switching to CPU mode
[CPU] estimating 3233x4767x544 disparity using 1078x954x8u tiles, offset -145
ocl_engine.cpp line 320: clWaitForEvents failed, error -9999
GPU processing failed, switching to CPU mode

Nvidia drivers are latest as of nov11

Any ideas?

Hope to get it going as this machine was built with photoscan in mind!

Cheers

-P
Lead Environtment Artist
Weta Digital

http://www.imdb.com/name/nm1473416/

bit-ks

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: GTX 760 GPU failed, switching to CPU mode
« Reply #4 on: November 20, 2014, 02:55:40 PM »
Hello,

I am using a GTX 970. Installing Drivers previouse of Version 340.52 is not possible, becaus the Driver doesn't recognise the card. Is there an upcoming patch or new Version to Support latest nvidia driver?

kind regards

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14937
    • View Profile
Re: GTX 760 GPU failed, switching to CPU mode
« Reply #5 on: November 20, 2014, 09:50:11 PM »
Hello bit-ks,

In version 1.1.0 compatibility issue is fixed.
Best regards,
Alexey Pasumansky,
Agisoft LLC