Forum

Author Topic: GPU processing failed  (Read 3373 times)

Kjellis85

  • Full Member
  • ***
  • Posts: 212
  • Archaeological field supervisor
    • View Profile
    • Contact information at University of Tromsø
GPU processing failed
« on: December 01, 2014, 11:44:22 AM »
I have a new rig with a Xeon E5-2630 v2, 64gb ram and a EVGA GeForce 980 GTX. When processing dense cloud I get this error in the console (see attachment). Why is this? Is it a driver issue or something else? The set I am running now only has about 20 images @20mb

stihl

  • Sr. Member
  • ****
  • Posts: 408
    • View Profile
Re: GPU processing failed
« Reply #1 on: December 01, 2014, 11:57:39 AM »
Hi

Yea that's due to a driver issue. Because the GPU fails during the dense cloud process it reverts back to the CPU which is immensely slower for this step than the GPU.

The solution is to roll back to driver version 337.88.

Kjellis85

  • Full Member
  • ***
  • Posts: 212
  • Archaeological field supervisor
    • View Profile
    • Contact information at University of Tromsø
Re: GPU processing failed
« Reply #2 on: December 01, 2014, 11:58:58 AM »
Ah, great, thanks for the quick response :D

Kjellis85

  • Full Member
  • ***
  • Posts: 212
  • Archaeological field supervisor
    • View Profile
    • Contact information at University of Tromsø
Re: GPU processing failed
« Reply #3 on: December 01, 2014, 01:27:13 PM »
Hmm, the 337.88 isn't compatible with the 980 gtx. Any suggestions?

stihl

  • Sr. Member
  • ****
  • Posts: 408
    • View Profile
Re: GPU processing failed
« Reply #4 on: December 01, 2014, 02:54:39 PM »
Oh that's unfortunate....

In that case I'm out of options. The only ones I can find for your card are v.344.xx which I assume produces these failures. :-\

3dmij

  • Newbie
  • *
  • Posts: 30
  • I make raspberry pi 3d Scanners
    • View Profile
    • pi3dscan
Re: GPU processing failed
« Reply #5 on: December 01, 2014, 04:54:19 PM »
So I have a GTX 970 and updated 2 days ago to the pre-release of the new agisoft software..

AND IT IS WONDERFUL!!! :-)

It fully supports the new nvidia drivers and wow, it is seriously faster then my i7 :-) I can now do a dense cloud in high render in 10 minutes, while this normally took over an hour :-)

Agisoft PhotoScan Version: 1.1.0 build 1995 (64 bit)
OpenGL Vendor: NVIDIA Corporation
OpenGL Renderer: GeForce GTX 970/PCIe/SSE2
OpenGL Version: 4.4.0 NVIDIA 344.75

With 6 out of 8 CPU cores enabled:
Device 1 performance: 45.1756 million samples/sec (CPU)
Device 2 performance: 574.931 million samples/sec (GeForce GTX 970)

With 0 out of 8 CPU cores enabled: (so only GPU):
Device 1 performance: 609.602 million samples/sec (GeForce GTX 970)

« Last Edit: December 01, 2014, 05:20:00 PM by 3dmij »