Forum

Author Topic: Urgent - Crashing when creating mesh  (Read 4306 times)

RachelDerbyshire

  • Newbie
  • *
  • Posts: 4
    • View Profile
Urgent - Crashing when creating mesh
« on: January 30, 2015, 12:20:02 AM »
Hi there,

I'm having an issue with Photoscan crashing when creating a mesh. Always seems to happen around the 30% mark.

My temps are fine (peaking at around 50 degrees celcius), but my CPU load is at 100%. It seems that when the CPU load it above 95% for 10 seconds it crashes.

I've got all the latest drivers, and have disabled the onboard GPU for my i5 incase that was causing a conflict.

I've been able to run a smaller mesh (total time around 10 seconds), so it seems the issue is related to prolonged stress on the CPU. It's worth noting that Windows doesn't give a BSOD (which I would expect if it were a hardware issue), it seems to be program specific.

I've tried reducing the number of CPU cores in use by photoscan from 4 to 1 to see if that would lessen the strain, but it made no different.

I've also repaired the installation and disconnected my second screen to try and narrow the problem down.

I have attached a crashlog, and my full system specs are:

Motherboard - Gigabyte H81M-S2H
Motherboard Expansion - 1x PCI Express x16, 2x PCI Express x1
Motherboard Features - Support for Q-Flash, Support for Xpress Install, EasyTune, EZ Setup, USB Blocker, Smart TimeLock, Smart Recovery 2

CPU Type - Intel I5 4th Generation Haswell
CPU Model - Intel Core I5 4460 3.2ghz 6mb Cache 4th Gen Haswell
CPU Socket - Intel 1150
CPU Speed - 3.2 Ghz
CPU Max Turbo Clock Speed - 3.4 Ghz
CPU Cooler - Standard Intel Cooler

Memory - 8GB DDR3 Performance Ram (1x 8GB stick)
Hard Drive Size - 120gb Kingston V300 Solid State Drive
Optical Drive -Samsung 24x Sata DVD Writer
Graphics Card - Nvidia Geforce GTX 970 4gb GDDR5
PSU Size - Corsair CX600 80 Plus Bronze Certified 600w Power Supply
Operating System - Windows 7 64bit

This is becoming increasingly urgent as I have deadlines to meet!. Any help would be much appreciated :)

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13811
    • View Profile
Re: Urgent - Crashing when creating mesh
« Reply #1 on: January 30, 2015, 12:31:16 AM »
Hello RachelDerbyshire,

Have you already submitted the crash report to us?

I can also suggest to check RAM modules with Memtest86 utility, just for case.
Best regards,
Alexey Pasumansky,
Agisoft LLC

RachelDerbyshire

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Urgent - Crashing when creating mesh
« Reply #2 on: January 30, 2015, 12:36:07 AM »
Hi There,

Thanks for the quick reply. I've sent the crash report over. WIll run memtest now...

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13811
    • View Profile
Re: Urgent - Crashing when creating mesh
« Reply #3 on: January 30, 2015, 02:55:54 PM »
Hello RachelDerbyshire,

What about test results?

Please also specify if the crashes are related to the certain project or can be reproduced on any medium-size dataset?
Best regards,
Alexey Pasumansky,
Agisoft LLC

RachelDerbyshire

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Urgent - Crashing when creating mesh
« Reply #4 on: January 30, 2015, 05:55:21 PM »
It happens on any medium size data set (anything over 20 photos). Memtest threw up loads of errors so I'm going to test tonight with a different stick of RAM to see if that was the issue. Shall keep you updated

RachelDerbyshire

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Urgent - Crashing when creating mesh
« Reply #5 on: January 31, 2015, 02:34:50 AM »
All fixed - the RAM was an the issue. Swapped the RAM stick for another one and all is well.

Thanks for your help.

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13811
    • View Profile
Re: Urgent - Crashing when creating mesh
« Reply #6 on: January 31, 2015, 10:34:36 AM »
Thank you for informing us.
Best regards,
Alexey Pasumansky,
Agisoft LLC