Forum

Author Topic: Circles in DEM  (Read 4539 times)

fsteiner

  • Newbie
  • *
  • Posts: 5
    • View Profile
Circles in DEM
« on: March 26, 2015, 04:02:44 PM »
Hello.

I am using PhotoScan to generate a Digital Elevation Model. I have almost 60 pictues, taken from a UAV platform, the coverage ist pretty well and I get a final result with a ground resolution of 2,2 cm.

I chose the following setting:
- Build Dense Cloud: Very high
- Build Mesh: highest Option; no interpolation
- Export DEM: suggested resolution (2,2cm)

The DEM looks normal, but when I use the DEM to calculate a shaded relief in ArcGIS, I can see many circles in some areas. They definitely come from the PhotoScan-model. My first idea was, that they might be because of the interpolation during mesh building, but even if turned off, they are still there. I tried several other options (resolution, quality-settings), but the result always shows these circles (see attached picture).

Any ideas where this is coming from, if it is a bug or something I can avoid?

Thanks,
fsteiner

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14837
    • View Profile
Re: Circles in DEM
« Reply #1 on: March 26, 2015, 04:40:41 PM »
Hello fsteiner,

Such artifacts usually indicate to the alignment issues affecting the dense cloud already, as mesh model is generated based on the dense cloud.

Also I don't think it is reasonable to use Ultra High quality for the dense cloud generation, as it requires very sharp and good quality images, but for aerial imagery it cannot be usually achieved.

Best regards,
Alexey Pasumansky,
Agisoft LLC

fsteiner

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Circles in DEM
« Reply #2 on: March 26, 2015, 06:08:34 PM »
Thank you for your answer.

I tried different settings for dense point cloud generation, the artifacts always appeared. I used the highest quality for the example picture I posted, but I also tried lower qualities.

What do you mean by "alignment issues affecting the dense cloud already"? Is there a way to improve the alignment, concerning these artifacts?

Thanks,
fsteiner

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14837
    • View Profile
Re: Circles in DEM
« Reply #3 on: March 26, 2015, 06:14:49 PM »
Hello fsteiner,

Maybe you can post the settings used for the camera alignment? Or, ideally, send us the project file (without dense cloud and mesh model to reduce the file size) to support@agisoft.com.
Best regards,
Alexey Pasumansky,
Agisoft LLC

ianicolo

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Circles in DEM
« Reply #4 on: April 03, 2015, 12:45:49 PM »
Hi. we observed the same artifacts on models that come from aerial images. We started to observe these artifacts  from one of the last  Agisoft release.  They appears in area of low images overlap. But if the general aerophotogrammetric dataset is characterized by low images number overlap, the circles are generated over the entire model.