Forum

Author Topic: ATI HD4XXX and OpenCL errors?  (Read 7077 times)

kosmarnik

  • Newbie
  • *
  • Posts: 5
    • View Profile
ATI HD4XXX and OpenCL errors?
« on: March 07, 2012, 12:55:15 AM »
Hi,
I'm evaluating PhotoScan and have run into a bug with the hd4870 and OpenCL:
Code: [Select]
error: can't enable all
          OpenCL extensions or unrecognized OpenCL extension
  #pragma OPENCL EXTENSION cl_khr_byte_addressable_store : enable

The initialization seems ok:
Code: [Select]
OpenGL Vendor: ATI Technologies Inc.
OpenGL Renderer: ATI Radeon HD 4800 Series
OpenGL Version: 3.3.11399 Compatibility Profile Context
Maximum Texture Size: 8192
ARB_vertex_buffer_object: supported
ARB_texture_non_power_of_two: supported


I've installed the latest Ati drivers, and after it didn't work even the ATI Stream APP SDK.

Searching a bit on the web if found some possibly relevant info:
Code: [Select]
This happens because the cl_khr_byte_addressable_store extension is not supported by 4000 series cards.

Which basically means you cant use chars the way program wants to, if someone can figure out how to modify the .cl file to use uint types instead of uchar types, then we can eliminate the need for the cl_khr_byte_addressable_store extension to be enabled and get this working on 4000 series cards.

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13917
    • View Profile
Re: ATI HD4XXX and OpenCL errors?
« Reply #1 on: March 07, 2012, 06:27:56 PM »
Hello kosmarnik,

Unfortunately PhotoScan supports ATI Radeon graphic cards starting from 5th series.
Best regards,
Alexey Pasumansky,
Agisoft LLC

kosmarnik

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: ATI HD4XXX and OpenCL errors?
« Reply #2 on: March 07, 2012, 11:53:01 PM »
Hello kosmarnik,

Unfortunately PhotoScan supports ATI Radeon graphic cards starting from 5th series.

It seems so but reading up a bit on other OpenCL projects that have hit the same problem, it could be an easy fix and worth your time.
« Last Edit: March 07, 2012, 11:54:50 PM by kosmarnik »

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13917
    • View Profile
Re: ATI HD4XXX and OpenCL errors?
« Reply #3 on: March 13, 2012, 01:21:29 PM »
Hello kosmarnik,

Since old graphic cards are not expected to give any visible process acceleration, we are not planning to implement support for old series.
Best regards,
Alexey Pasumansky,
Agisoft LLC