Forum

Author Topic: SSL SUPPORT NOT AVAILABLE  (Read 8378 times)

Uygar

  • Newbie
  • *
  • Posts: 25
    • View Profile
SSL SUPPORT NOT AVAILABLE
« on: November 07, 2015, 08:16:10 AM »
When ı upload ortomosaic to mapbox ı have this message "SSL SUPPORT NOT AVAILABLE"  . what can ı do , whats wrong ?

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13051
    • View Profile
Re: SSL SUPPORT NOT AVAILABLE
« Reply #1 on: November 10, 2015, 04:16:12 PM »
Hello Uygar,

To use MapBox upload feature it is required to have SSL support that is not included to PhotoScan installation package by default.

You can download and install it manually from the following page:
http://slproweb.com/products/Win32OpenSSL.html


Direct link for Windows 64-bit version:
http://slproweb.com/download/Win64OpenSSL_Light-1_0_2d.exe
Best regards,
Alexey Pasumansky,
Agisoft LLC

Uygar

  • Newbie
  • *
  • Posts: 25
    • View Profile
Re: SSL SUPPORT NOT AVAILABLE
« Reply #2 on: November 13, 2015, 10:57:12 AM »
thank you , i will try .

kgrover

  • Newbie
  • *
  • Posts: 39
    • View Profile
Re: SSL SUPPORT NOT AVAILABLE
« Reply #3 on: November 13, 2015, 11:43:01 PM »
I tried this as well, and I don't get the SSL error anymore, but now i just get an Out of Memory error when trying to upload.

Any ideas?

Kevin

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13051
    • View Profile
Re: SSL SUPPORT NOT AVAILABLE
« Reply #4 on: November 18, 2015, 11:02:01 AM »
Hello Kevin,

What is the size of the orthomosaic (in Upload dialog)?
Best regards,
Alexey Pasumansky,
Agisoft LLC

kgrover

  • Newbie
  • *
  • Posts: 39
    • View Profile
Re: SSL SUPPORT NOT AVAILABLE
« Reply #5 on: November 18, 2015, 05:59:10 PM »
So I don't seem to get the out of memory error now, but then i get other errors.

I have finally gotten to the upload stage, and it goes thru the upload process, then get the attached error with the details here:

<?xml version="1.0" encoding="UTF-8"?>
<Error><Code>XAmzContentSHA256Mismatch</Code><Message>The provided 'x-amz-content-sha256' header does not match what was computed.</Message><ClientComputedContentSHA256>2664c0769026fb06606e7429b4016e15d5e0b3bd6573bf6b54a992c0782c6441</ClientComputedContentSHA256><S3ComputedContentSHA256>9629a7f40d2ff4032da027bc06a687a595a955c9a3fc7ee92e18b70cfa6f16fb</S3ComputedContentSHA256><RequestId>A936C3C52C7CBBB5</RequestId><HostId>y+j5ekqofajWj4iakUNjCbqumj260+XIdwQI0t8TuRnGAtGoS5yRrNOgaItPJArgQV7YftE4qwU=</HostId></Error>

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13051
    • View Profile
Re: SSL SUPPORT NOT AVAILABLE
« Reply #6 on: December 05, 2015, 04:54:55 PM »
Hello kgrover,

Seems like an issue with Amazon servers, we weren't able to reproduce it on any project and in different periods of time. Does this problem still exist on your side?
Best regards,
Alexey Pasumansky,
Agisoft LLC

kgrover

  • Newbie
  • *
  • Posts: 39
    • View Profile
Re: SSL SUPPORT NOT AVAILABLE
« Reply #7 on: December 07, 2015, 06:07:19 PM »
HI Alexey,

I just tried again, and i am still getting the same error.

Kevin

sastun1962

  • Newbie
  • *
  • Posts: 36
    • View Profile
Re: SSL SUPPORT NOT AVAILABLE
« Reply #8 on: February 03, 2018, 05:15:09 PM »
Hi, after a windows reinstalling (and PS too) I have this error tryng to upload a model to Sketchfab...
What can I do please?

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13051
    • View Profile
Re: SSL SUPPORT NOT AVAILABLE
« Reply #9 on: February 03, 2018, 06:13:14 PM »
Hello sastun1962,

Installing OpenSSL should fix the issue. Some users with similar problem recently have reported that installing OpenSSL v1.0.2n or OpenSSL v1.0.2n Light works fine.
Best regards,
Alexey Pasumansky,
Agisoft LLC

sastun1962

  • Newbie
  • *
  • Posts: 36
    • View Profile
Re: SSL SUPPORT NOT AVAILABLE
« Reply #10 on: February 04, 2018, 06:12:52 PM »
Hi Alexey,
I have try but without success...
what can be tha problem?
thanks
Massimo

sastun1962

  • Newbie
  • *
  • Posts: 36
    • View Profile
Re: SSL SUPPORT NOT AVAILABLE
« Reply #11 on: February 06, 2018, 11:24:08 AM »
Hi, no one can be explain how to resolve the SSL error please?

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13051
    • View Profile
Re: SSL SUPPORT NOT AVAILABLE
« Reply #12 on: February 07, 2018, 02:37:48 PM »
Hello Massimo,

Regularly, installation of OpenSSL libraries (when they are missing) fixes the issue. In some cases it may be necessary to install both 32-bit and 64-bit packages.
Best regards,
Alexey Pasumansky,
Agisoft LLC