Forum

Author Topic: Memory issues when building Texture.  (Read 2599 times)

Brishen

  • Newbie
  • *
  • Posts: 3
    • View Profile
Memory issues when building Texture.
« on: March 01, 2016, 06:55:07 PM »
Most of my memory issues come around when I get to trying to build texture. I've been playing around with the options and nothing changes.

The pictures I have been using are 3264x2448 and I normally use 12-60 of them at a time to align, build dense cloud, build mesh. Unfortunately when I get to building texture that is when I run into memory issues I can't get around.

I have 32gb of ram and honestly not sure what I am doing wrong at this point.

Computer Build
Intel Core i7-6700K
2x GeIL SUPER LUCE 16GB DDR4-2400(PC4-19200)
MSI Radeon R9 Nano4GB 4096-Bit HBM PCIe 3.0 HDCP CrossFireX

Any advice?

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14890
    • View Profile
Re: Memory issues when building Texture.
« Reply #1 on: March 01, 2016, 07:18:45 PM »
Hello Brishen,

What settings you are using in the Build Texture dialog?

Also can you provide the console pane output related to the operation?
Best regards,
Alexey Pasumansky,
Agisoft LLC

Brishen

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Memory issues when building Texture.
« Reply #2 on: March 01, 2016, 07:39:23 PM »
I've tried all the Mapping modes but not all the blending mode options associated with each mapping mode.

This is what I get when I use generic, mosaic, 1024.

Quote
2016-03-02 00:36:56 Parameterizing texture atlas...
2016-03-02 00:37:06 Packing 221 charts...
2016-03-02 00:37:11 Blending textures...
2016-03-02 00:37:11 blending textures... ???????*Finished processing in 16.047 sec (exit code 0)
2016-03-02 00:37:12 Error: bad allocation

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14890
    • View Profile
Re: Memory issues when building Texture.
« Reply #3 on: March 01, 2016, 07:44:19 PM »
Hello Brishen,

Is it possible that you have accidentally installed 32-bit version of PhotoScan?
Best regards,
Alexey Pasumansky,
Agisoft LLC

Brishen

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Memory issues when building Texture.
« Reply #4 on: March 01, 2016, 08:04:58 PM »
I don't think so but I'll check when I wake up tomorrow, when I wake up. Its 1am where I am currently.